Skip to content
Permalink
Browse files

Merge branch 'ypid-fix/buster-backports'

  • Loading branch information...
drybjed committed Sep 5, 2019
2 parents 2a5d05c + 458fa43 commit 0d6e3223fe6dd4fa36e21dbeeeb581261b350409
@@ -55,6 +55,11 @@ Updates of upstream application versions
``12.1``. This is the last release that supports Ruby 2.5 which is included
in Debian Buster.

:ref:`debops.apt_preferences` role
''''''''''''''''''''''''''''''''''

- Support Debian Buster in :ref:`apt_preferences__list`.

:ref:`debops.resolvconf` role
'''''''''''''''''''''''''''''

@@ -20,6 +20,12 @@
vars:

# Map of current and next distribution releases
# Redundant in the following places, please update all copies:
#
# * ansible/roles/debops.apt/defaults/main.yml
# * ansible/roles/debops.apt_preferences/defaults/main.yml
# * ansible/roles/debops.reprepro/defaults/main.yml
# * ansible/playbooks/tools/dist-upgrade.yml
dist_upgrade_version_map:
'wheezy': 'jessie'
'jessie': 'stretch'
@@ -160,6 +160,14 @@ apt_preferences__priority_version: 1001
# Dictionary of future releases of current stable distributions. This is used to
# check if the role can create autogenerated pins with preference for backported
# packages from the ``<release>-backports`` repository.
#
# .. Redundant in the following places, please update all copies:
#
# * ansible/roles/debops.apt/defaults/main.yml
# * ansible/roles/debops.apt_preferences/defaults/main.yml
# * ansible/roles/debops.reprepro/defaults/main.yml
# * ansible/playbooks/tools/dist-upgrade.yml
#
apt_preferences__next_release:

# Debian releases
@@ -168,6 +176,8 @@ apt_preferences__next_release:
'wheezy': 'jessie'
'jessie': 'stretch'
'stretch': 'buster'
'buster': 'bullseye'
'bullseye': 'bookworm'

# Ubuntu releases
'precise': 'quantal'
@@ -811,22 +811,40 @@ reprepro_nginx_server_https:
# .. envvar:: reprepro_debian_previous [[[
#
# Debian previous releases
#
# .. Redundant in the following places, please update all copies:
#
# * ansible/roles/debops.apt/defaults/main.yml
# * ansible/roles/debops.apt_preferences/defaults/main.yml
# * ansible/roles/debops.reprepro/defaults/main.yml
# * ansible/playbooks/tools/dist-upgrade.yml
#
reprepro_debian_previous:
'wheezy': 'squeeze'
'jessie': 'wheezy'
'stretch': 'jessie'
'buster': 'stretch'
'bullseye': 'buster'
'bookworm': 'bullseye'

# ]]]
# .. envvar:: reprepro_debian_next [[[
#
# Debian next releases
#
# .. Redundant in the following places, please update all copies:
#
# * ansible/roles/debops.apt/defaults/main.yml
# * ansible/roles/debops.apt_preferences/defaults/main.yml
# * ansible/roles/debops.reprepro/defaults/main.yml
# * ansible/playbooks/tools/dist-upgrade.yml
#
reprepro_debian_next:
'wheezy': 'jessie'
'jessie': 'stretch'
'stretch': 'buster'
'buster': 'bullseye'
'bullseye': 'bookworm'

# ]]]
# .. envvar:: reprepro_debian_releases [[[

0 comments on commit 0d6e322

Please sign in to comment.
You can’t perform that action at this time.