Permalink
Browse files

SimpleForm 2.0.1

  • Loading branch information...
1 parent 5336dfc commit ade5eca6bab1020597945863d05556b983a8488a @decioferreira committed Feb 29, 2012
Showing with 7 additions and 4 deletions.
  1. +4 −4 README.md
  2. +3 −0 lib/generators/bootstrap/install/templates/config/initializers/simple_form.rb
View
@@ -12,9 +12,9 @@ Or you can install from latest build:
gem 'bootstrap-generators', '~> 2.0', :git => 'git://github.com/decioferreira/bootstrap-generators.git'
-By default Bootstrap Generators requires [SimpleForm 2.0.0.rc](https://github.com/plataformatec/simple_form). Add the dependency on your Gemfile:
+By default Bootstrap Generators requires [SimpleForm 2.0](https://github.com/plataformatec/simple_form). Add the dependency on your Gemfile:
- gem 'simple_form', '2.0.0.rc'
+ gem 'simple_form', '~> 2.0'
If you don't want to use SimpleForm, just pass the `--form_builder=form_builder` option:
@@ -77,9 +77,9 @@ To select one of these layouts just pass the option `--layout=LAYOUT` to the ins
* SimpleForm
-By default Bootstrap Generators requires SimpleForm 2.0.0.rc. Add the dependency on your Gemfile:
+By default Bootstrap Generators requires SimpleForm 2.0. Add the dependency on your Gemfile:
- gem 'simple_form', '2.0.0.rc'
+ gem 'simple_form', '~> 2.0'
And then run:
@@ -46,6 +46,7 @@
end
config.wrappers :bootstrap, :tag => 'div', :class => 'control-group', :error_class => 'error' do |b|
+ b.use :html5
b.use :placeholder
b.use :label
b.wrapper :tag => 'div', :class => 'controls' do |ba|
@@ -56,6 +57,7 @@
end
config.wrappers :prepend, :tag => 'div', :class => "control-group", :error_class => 'error' do |b|
+ b.use :html5
b.use :placeholder
b.use :label
b.wrapper :tag => 'div', :class => 'controls' do |input|
@@ -68,6 +70,7 @@
end
config.wrappers :append, :tag => 'div', :class => "control-group", :error_class => 'error' do |b|
+ b.use :html5
b.use :placeholder
b.use :label
b.wrapper :tag => 'div', :class => 'controls' do |input|

0 comments on commit ade5eca

Please sign in to comment.