P2 Troubleshooting

Joe Hellerstein edited this page Dec 8, 2015 · 2 revisions

Troubleshooting

P2 on Ubuntu Linux

Packages Needed

Add the Ubuntu universe repository to /etc/apt/sources.list and then run the following:

sudo apt-get install flex automake1.9 g++ libtool bison
sudo apt-get install libboost*
sudo apt-get install libssl-dev

You may need to update-alternatives automake to point to 1.9. This has been tested on 6.10-server (Edgy).

General Troubleshooting

I have a rule with a periodic predicate that isn't firing.

The periodic predicate must be the first one in the rule body with the current parser and planner. We are currently working on fixing this.