Permalink
Browse files

Merge pull request #2 from rjlee/master

Fix for shape markers
  • Loading branch information...
2 parents 412b6cb + c05d77c commit f6572160fb54c799ddd71ef859b135f44323f71a @deepakjois committed May 11, 2011
Showing with 1 addition and 2 deletions.
  1. +1 −2 lib/google_chart/modules/markers.rb
@@ -75,8 +75,7 @@ def validate_shape_marker(marker)
marker.data_set >= 0
raise ArgumentError.new("Invalid data set value. Must be and integer less than #{@data[marker.data_set].length}") unless marker.data_point.is_a?(Integer) and
- marker.data_point < @data[marker.data_set].length and
- marker.data_point >= 0
+ marker.data_point < @data[marker.data_set].length
raise ArgumentError.new("Invalid priority. :priority must be either :low or :high") unless marker.priority == nil or
PRIORITY.keys.include?(marker.priority)

0 comments on commit f657216

Please sign in to comment.