Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Commits on Apr 28, 2009
  1. @luislavena
Commits on Apr 25, 2009
  1. @luislavena
  2. @luislavena

    Updated Gem generation to use latest RubyGems

    luislavena authored
    Changed format and task for gem generation, used
    in development.
    
    Now it requires RubyGems 1.3.2 to contribute.
    
    Please see RubyGems project at RubyForge for install
    instructions.
    
      http://www.rubyforge.org/projects/rubygems
  3. @luislavena
  4. @luislavena

    Allow generation of multiple gems for Windows

    luislavena authored
    - This allows build gems for both VC6 and MinGW builts of Ruby.
    
        Rake::ExtensionTask.new('my_extension', GEM_SPEC) do |ext|
          ext.cross_compile = true
          ext.cross_platform = ['i386-mswin32', 'i386-mingw32']
        end
    
    This is highly experimental and exposed the need to refactor
    ExtensionTask internals. Right now it fires the compilation
    process twice, which is suboptimal.
  5. @luislavena

    Tweak: changed describe to context for specs.

    luislavena authored
    Made more sense for nested example groups.
Commits on Apr 17, 2009
  1. More sexy solution :)

    authored
  2. Fixed path

    authored
  3. Added SOURCE flag for cross-ruby

    authored
  4. @luislavena

    Proper detection of native C extension binary.

    luislavena authored
    (First commit to correct features from OSX) Yay!
Commits on Apr 15, 2009
  1. @luislavena

    Stop poluting World.

    luislavena authored
    In other words, updated to Cucumber 0.3 and changed way
    helpers get loaded for features.
Commits on Apr 10, 2009
  1. @luislavena
  2. @luislavena
Commits on Apr 9, 2009
  1. @luislavena

    Released Version 0.4.1!

    luislavena authored
  2. @luislavena
  3. @luislavena

    Fixed broken specs for rake-compiler configuration.

    luislavena authored
    - It no longer raises an error, but instead a warning.
    - Uses captured console output.
  4. @luislavena

    Added Console redirection helper

    luislavena authored
    The idea is be able to capture output from OUT and ERR in the
    specs.
  5. @luislavena

    Messing with History format for announce and release.

    luislavena authored
    I know, I keep messing with that file, but I like the new
    format with Darkfish.
  6. @luislavena

    A huge change in RDoc.

    luislavena authored
    Started to use latest RDoc package instead of Rake one.
  7. @luislavena

    Shame on me. Missed the announce and change format!

    luislavena authored
    Updated Change formatting and missed to update the tasks.
    (this is only usable for me for release, so).
  8. @tenderlove @luislavena

    yay! awesome version hack

    tenderlove authored luislavena committed
    Signed-off-by: Luis Lavena <luislavena@gmail.com>
  9. @tenderlove @luislavena

    when packaging binary gems, make sure that the required ruby version …

    tenderlove authored luislavena committed
    …is set to the ruby version we used for cross compiling
    
    Signed-off-by: Luis Lavena <luislavena@gmail.com>
  10. @tenderlove @luislavena

    only warning when there is no rbconfig

    tenderlove authored luislavena committed
    Signed-off-by: Luis Lavena <luislavena@gmail.com>
Commits on Apr 4, 2009
  1. @luislavena

    Mark for release 0.4.0

    luislavena authored
Commits on Apr 3, 2009
  1. @luislavena
  2. @luislavena
Commits on Mar 22, 2009
  1. @luislavena

    Implement Ruby version faker.

    luislavena authored
    During cross compilation, rake-compiler will create a fake.rb
    file to mimic a different version than the one used to execute
    the build process.
    
    Yet still, there are some changes between 1.9 and 1.8 not yet
    ironed.
  2. @luislavena

    Track full Ruby version (x.y.z) when cross-compiling.

    luislavena authored
    Exposed also 'update-config' task for rake-compiler so
    migration to new syntax is possible.
Commits on Mar 21, 2009
  1. @luislavena
  2. @luislavena

    Allow X.Y.Z version of Ruby be specified.

    luislavena authored
    This is part of the work required for getting you
    compile a extension from one version of ruby targetting another.
Commits on Feb 23, 2009
  1. @luislavena
  2. @luislavena
  3. @luislavena

    Use Gem::Platform to construct native gem.

    luislavena authored
    It stored inside the gem metadata the incorrect platform format,
    which lead to mismatched gem names during indexing by RubyForge.
    
    This change fixes the issue DataMapper and other gem authors
    faced.
Something went wrong with that request. Please try again.