Permalink
Switch branches/tags
Nothing to show
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
71 lines (65 sloc) 2.28 KB
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = %q{haphazard}
s.version = "0.3.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["eddie cianci"]
s.date = %q{2010-11-06}
s.description = %q{adds a random() method to your activerecord models. respects where conditions and joins.}
s.email = %q{defeated2k4@gmail.com}
s.extra_rdoc_files = [
"LICENSE.txt",
"README.rdoc"
]
s.files = [
".document",
".rspec",
"Gemfile",
"Gemfile.lock",
"LICENSE.txt",
"README.rdoc",
"Rakefile",
"VERSION",
"haphazard.gemspec",
"lib/haphazard.rb",
"spec/haphazard_spec.rb",
"spec/spec_helper.rb"
]
s.homepage = %q{http://github.com/defeated/haphazard}
s.require_paths = ["lib"]
s.rubygems_version = %q{1.3.7}
s.summary = %q{returns a random activerecord model instance}
s.test_files = [
"spec/haphazard_spec.rb",
"spec/spec_helper.rb"
]
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<activerecord>, ["~> 3.0"])
s.add_development_dependency(%q<rspec>, ["~> 2.0.0"])
s.add_development_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_development_dependency(%q<jeweler>, ["~> 1.5.0.pre5"])
s.add_development_dependency(%q<rcov>, [">= 0"])
s.add_development_dependency(%q<acts_as_fu>, [">= 0"])
else
s.add_dependency(%q<activerecord>, ["~> 3.0"])
s.add_dependency(%q<rspec>, ["~> 2.0.0"])
s.add_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_dependency(%q<jeweler>, ["~> 1.5.0.pre5"])
s.add_dependency(%q<rcov>, [">= 0"])
s.add_dependency(%q<acts_as_fu>, [">= 0"])
end
else
s.add_dependency(%q<activerecord>, ["~> 3.0"])
s.add_dependency(%q<rspec>, ["~> 2.0.0"])
s.add_dependency(%q<bundler>, ["~> 1.0.0"])
s.add_dependency(%q<jeweler>, ["~> 1.5.0.pre5"])
s.add_dependency(%q<rcov>, [">= 0"])
s.add_dependency(%q<acts_as_fu>, [">= 0"])
end
end