Skip to content
This repository
Fetching contributors…

Octocat-spinner-32-eaf2f5

Cannot retrieve contributors at this time

file 46 lines (38 sloc) 1.245 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45
require 'rubygems'
require 'rake'

begin
  require 'echoe'

  Echoe.new('github', '0.4.3') do |p|
    p.rubyforge_name = 'github'
    p.summary = "The official `github` command line helper for simplifying your GitHub experience."
    p.description = "The official `github` command line helper for simplifying your GitHub experience."
    p.url = "http://github.com/"
    p.author = ['Chris Wanstrath', 'Kevin Ballard', 'Scott Chacon', 'Dr Nic Williams']
    p.email = "drnicwilliams@gmail.com"
    p.dependencies = [
      "text-format >=1.0.0",
      "highline ~>1.5.1",
      "json >=1.2.0"
    ]
  end

rescue LoadError => boom
  puts "You are missing a dependency required for meta-operations on this gem."
  puts "#{boom.to_s.capitalize}."
end

# add spec tasks, if you have rspec installed
begin
  require 'spec/rake/spectask'

  Spec::Rake::SpecTask.new("spec") do |t|
    t.spec_files = FileList['spec/**/*_spec.rb']
    t.spec_opts = ['--color']
  end

  task :test do
    Rake::Task['spec'].invoke
  end

  Spec::Rake::SpecTask.new("rcov_spec") do |t|
    t.spec_files = FileList['spec/**/*_spec.rb']
    t.spec_opts = ['--color']
    t.rcov = true
    t.rcov_opts = ['--exclude', '^spec,/gems/']
  end
end
Something went wrong with that request. Please try again.