Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

github gem requires json gem, but doesn't depend on it #11

Closed
indirect opened this Issue Dec 5, 2009 · 3 comments

Comments

Projects
None yet
3 participants

indirect commented Dec 5, 2009

The github gem should depend on the json gem, so that gem install github will install it.

I installed the github gem, but when I ran gh, I got this:

/Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- json (LoadError)
    from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
    from /usr/local/Cellar/Gems/1.8/gems/github-0.4.0/bin/../lib/github.rb:9
    from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
    from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
    from /usr/local/Cellar/Gems/1.8/gems/github-0.4.0/bin/gh:6
    from /usr/local/bin/gh:19:in `load'
    from /usr/local/bin/gh:19

pnutus commented Jan 25, 2010

This is a dupe of issue 10.

Huh, weird. I definitely didn't see issue 10 at the time. Thanks.

Collaborator

drnic commented Apr 28, 2010

Fixed now.

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment