Permalink
Browse files

Get Sake out of dependency hell.

- Require ParseTree and ruby2ruby with '>=' and not '='
- Update the error message shown when depends are not met.
- Bump version to 1.0.16 even though local code only refs 1.0.14 since rubyforge is serving 1.0.15 (?)

Without these changes Sake is having troubles since it is requiring old versions of its required
gems.  So install and gem cleanup is a bit painful.
  • Loading branch information...
1 parent 6b61dc1 commit 4924b181ef9e1e9c9f6882622db538fe69976837 @grempe grempe committed Jul 9, 2008
Showing with 5 additions and 5 deletions.
  1. +1 −1 Rakefile
  2. +4 −4 lib/sake.rb
View
@@ -13,7 +13,7 @@ begin
p.url = "http://errtheblog.com/"
p.author = 'Chris Wanstrath'
p.email = "chris@ozmm.org"
- p.dependencies = ['ParseTree =2.1.1', 'ruby2ruby =1.1.8']
+ p.dependencies = ['ParseTree >=2.1.1', 'ruby2ruby >=1.1.8']
end
rescue LoadError => boom
View
@@ -9,12 +9,12 @@
require 'fileutils'
require 'open-uri'
begin
- gem 'ParseTree', '=2.1.1'
+ gem 'ParseTree', '>=2.1.1'
require 'parse_tree'
- gem 'ruby2ruby', '=1.1.8'
+ gem 'ruby2ruby', '>=1.1.8'
require 'ruby2ruby'
rescue LoadError
- puts "# Sake requires the ruby2ruby gem and Ruby 1.8.6."
+ puts "# Sake requires the ParseTree and ruby2ruby gems and Ruby >=1.8.6."
exit
end
require File.dirname(__FILE__) + '/help'
@@ -77,7 +77,7 @@ class Sake
module Version #:nodoc:
Major = '1'
Minor = '0'
- Tweak = '14'
+ Tweak = '16'
String = [ Major, Minor, Tweak ].join('.')
end

1 comment on commit 4924b18

Please push this version of the gem to rubyforge, only 1.0.15 is there and it still has the dependency issues which annoyed me today.

Please sign in to comment.