Permalink
Browse files

Sandbox: document SIGUSR2 + bundler issue with 2.0.0

Thanks to Eric Chapweske for the heads up.

ref: http://mid.gmane.org/loom.20130904T205308-432@post.gmane.org
  • Loading branch information...
1 parent 9af083d commit 849348f82830326e7778e50a5a7f2efeeb4460e5 Eric Wong committed Sep 4, 2013
Showing with 7 additions and 0 deletions.
  1. +7 −0 Sandbox
View
@@ -60,6 +60,13 @@ If you're using an older Bundler version (0.9.x), you may need to set or
reset GEM_HOME, GEM_PATH and PATH environment variables in the
before_exec hook as illustrated by http://gist.github.com/534668
+=== Ruby 2.0.0 close-on-exec and SIGUSR2 incompatibility
+
+Ruby 2.0.0 enforces FD_CLOEXEC on file descriptors by default. unicorn
+has been prepared for this behavior since unicorn 4.1.0, but we forgot
+to remind the Bundler developers. This issue is being tracked here:
+https://github.com/bundler/bundler/issues/2628
+
== Isolate
=== Running

0 comments on commit 849348f

Please sign in to comment.