Permalink
Browse files

move Rails 2.3.x test to Rails 2.3.8

This allows us to gets rid of the Rack 1.0.1 dependency when
running Rails tests since previous versions of Rails 2.3.x
needed Rack 1.0.1, where as Rails 2.2.x and below could be used
with any version of Rack (under Unicorn only).
  • Loading branch information...
1 parent 4b44e21 commit 8e55e561a1bcba57bf429c9c2111ec5351fcb1b3 Eric Wong committed Jun 3, 2010
View
@@ -1,11 +1,12 @@
= Frequently Asked Questions about Unicorn
-=== I've installed Rack 1.1.x, why can't Unicorn load Rails?
+=== I've installed Rack 1.1.x, why can't Unicorn load Rails (2.3.5)?
Rails 2.3.5 is not compatible with Rack 1.1.x. Unicorn is compatible
with both Rack 1.1.x and Rack 1.0.x, and RubyGems will load the latest
version of Rack installed on the system. Uninstalling the Rack 1.1.x
-gem should solve gem loading issues with Rails 2.3.x.
+gem should solve gem loading issues with Rails 2.3.5. Rails 2.3.6
+and later correctly support Rack 1.1.x.
=== Why are my redirects going to "http" URLs when my site uses https?
View
@@ -208,6 +208,11 @@ $(rails_git)/info/cloned-stamp:
git clone --mirror -q $(rails_git_url) $(rails_git)
> $@
+$(rails_git)/info/v2.3.8-stamp: $(rails_git)/info/cloned-stamp
+ cd $(rails_git) && git fetch
+ cd $(rails_git) && git rev-parse --verify refs/tags/v2.3.8
+ > $@
+
rails_tests := $(addsuffix .r,$(addprefix $(T_r).,$(rails_vers)))
test-rails: $(rails_tests)
$(T_r).%.r: t = $(addsuffix $(log_suffix),$@)
@@ -218,7 +223,7 @@ $(T_r).%.r: export PATH := $(test_prefix)/bin:$(PATH)
$(T_r).%.r: export RUBYLIB := $(test_prefix):$(test_prefix)/lib:$(RUBYLIB)
$(T_r).%.r: export UNICORN_RAILS_TEST_VERSION = $(rv)
$(T_r).%.r: export RAILS_GIT_REPO = $(CURDIR)/$(rails_git)
-$(T_r).%.r: $(test_prefix)/.stamp $(rails_git)/info/cloned-stamp
+$(T_r).%.r: $(test_prefix)/.stamp $(rails_git)/info/v2.3.8-stamp
$(run_test)
ifneq ($(VERSION),)
File renamed without changes.

0 comments on commit 8e55e56

Please sign in to comment.