Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Simple Redis store for OpenID
branch: master

Merge pull request #2 from yb66/master

Added a litte on requiring the lib, and installing with bundler
latest commit ba4761c3b5
Aleksey Dmitriev authored
Failed to load latest commit information.
lib auto load
.gitignore
README.md The require line wasn't immediately apparent to me, so added it here,…
Rakefile
openid-redis-store.gemspec update version, add myself to author and email

README.md

Redis Store for OpenID

This is a simple store for OpenID authentication.

Requirements

Requires ruby-openid, redis Ruby library and Redis 2.x.x.

Usage

Install the plugin, either by:

./script/plugin install git://github.com/dekart/openid-redis-store.git

Or with bundler, put this in your Gemfile:

gem "openid-redis-store"

Require the library via:

require 'openid_redis_store'

Set your OpenID store (for Rails put this to a new file in config/initializers):

# Initializing Redis client
redis_client = Redis.new(
  :host => "127.0.0.1",
  :port => "",
  :db   => 0
)

OpenIdAuthentication.store = OpenID::Store::Redis.new(redis_client)

Testing

No tests yet :( You can fork this plugin at GitHub (http://github.com/dekart/openid-redis-store) and add your own tests. I'll be happy to accept patches!

Credits

Written by Alex Dmitriev

Something went wrong with that request. Please try again.