Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
tag: jetty-7-to-jet…
Fetching contributors…

Cannot retrieve contributors at this time

file 230 lines (230 sloc) 8.275 kb
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<linux-packaging>
  <mapping>
    <dependency>
      <groupId>org.mortbay.jetty</groupId>
      <artifactId>jsp-api-2.1-glassfish</artifactId>
      <debian available="false"/>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>ch.qos.logback</groupId>
      <artifactId>logback-classic</artifactId>
      <required-classes>
        <class>ch.qos.logback.classic.LoggerContext</class>
      </required-classes>
      <debian criteria="&gt;= 0.9.18">liblogback-java</debian>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>javax.servlet</groupId>
      <artifactId>servlet-api</artifactId>
      <version>2.5</version>
      <required-classes>
        <class>javax.servlet.http.HttpServlet</class>
      </required-classes>
      <debian available="false"/>
      <redhat avaialble="false">tomcat6-servlet-2.5-api</redhat>
    </dependency>
    <dependency>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      <!-- In order to assure proper packaging setup, a few classes
should be specified to check for on the classpath.
If these classes are not present on the classpath, then
the jar is downloaded from the maven repo and used in
an embedded fashion. -->
      <required-classes>
        <class>junit.framework.Assert</class>
        <class>junit.framework.TestCase</class>
      </required-classes>
      <!-- The debian packaging refers to the version-less package name.
An optional criteria can be specified that would indicate
a minimum version to be present on the system.
This information will (eventually) be verified against
the debian/control file to ensure that the packaging
is still valid.
If the information is determined to not be present
in the debian/control file than a build error is
(hopefully) produced to let the maintainers know
that this information is now out of date. -->
      <debian criteria="&gt;= 3.8">junit</debian>
      <redhat>junit</redhat>
    </dependency>
    <dependency>
      <groupId>org.eclipse.jdt.core.compiler</groupId>
      <artifactId>ecj</artifactId>
      <debian available="false"/>
      <redhat>ecj</redhat>
    </dependency>
    <dependency>
      <groupId>org.mortbay.jetty</groupId>
      <artifactId>jsp-2.1-glassfish</artifactId>
      <debian available="false"/>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>ch.qos.logback</groupId>
      <artifactId>logback-core</artifactId>
      <required-classes>
        <class>ch.qos.logback.core.joran.JoranConfiguratorBase</class>
      </required-classes>
      <debian criteria="&gt;= 0.9.18">liblogback-java</debian>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>org.apache.geronimo.specs</groupId>
      <artifactId>geronimo-jaspic_1.0_spec</artifactId>
      <debian available="false"/>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>org.eclipse.equinox.http</groupId>
      <artifactId>servlet</artifactId>
      <debian criteria="&gt;= 3.5">eclipse-platform</debian>
    </dependency>
    <dependency>
      <groupId>org.eclipse.osgi</groupId>
      <artifactId>services</artifactId>
      <debian available="false"/>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>org.apache.geronimo.specs</groupId>
      <artifactId>geronimo-jta_1.1_spec</artifactId>
      <debian available="false">libgeronimo-jta-1.1-spec-1.1.1-java</debian>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>org.eclipse</groupId>
      <artifactId>osgi</artifactId>
      <required-classes>
        <class>org.osgi.framework.BundleContext</class>
      </required-classes>
      <debian available="false"/>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>org.slf4j</groupId>
      <artifactId>jcl-over-slf4j</artifactId>
      <debian criteria="&gt;= 1.5.10">libslf4j-java</debian>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>asm</groupId>
      <artifactId>asm-commons</artifactId>
      <debian criteria="&gt;= 3.1">libasm3-java</debian>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>ant</groupId>
      <artifactId>ant</artifactId>
      <debian criteria="&gt;= 1.6">ant</debian>
      <redhat>ant</redhat>
    </dependency>
    <dependency>
      <groupId>asm</groupId>
      <artifactId>asm</artifactId>
      <debian criteria="&gt;= 3.1">libasm3-java</debian>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>asm</groupId>
      <artifactId>asm-tree</artifactId>
      <debian criteria="&gt;= 3.1">libasm3-java</debian>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>javax.mail</groupId>
      <artifactId>mail</artifactId>
      <required-classes>
        <class>javax.mail.Authenticator</class>
        <class>javax.mail.PasswordAuthentication</class>
        <class>javax.mail.Session</class>
      </required-classes>
      <debian>libgnumail-java</debian>
      <redhat>sun-mail</redhat>
    </dependency>
    <dependency>
      <groupId>org.apache.geronimo.specs</groupId>
      <artifactId>geronimo-annotation_1.0_spec</artifactId>
      <debian available="false"/>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>org.slf4j</groupId>
      <artifactId>log4j-over-slf4j</artifactId>
      <debian criteria="&gt;= 1.5.10">libslf4j-java</debian>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>org.testng</groupId>
      <artifactId>testng</artifactId>
      <debian criteria="&gt;= 5.8">testng</debian>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>org.mortbay.jetty</groupId>
      <artifactId>servlet-api</artifactId>
      <version>3.0.20100224</version>
      <required-classes>
        <class>javax.servlet.AsyncContext</class>
        <class>javax.servlet.AsyncEvent</class>
        <class>javax.servlet.AsyncListener</class>
      </required-classes>
      <debian available="false"/>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>org.slf4j</groupId>
      <artifactId>slf4j-api</artifactId>
      <required-classes>
        <class>org.slf4j.Logger</class>
      </required-classes>
      <debian criteria="&gt;= 1.5.10">libslf4j-java</debian>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>org.mortbay.jetty</groupId>
      <artifactId>jetty-util</artifactId>
      <debian available="false"/>
      <redhat available="false"/>
    </dependency>
    <dependency>
      <groupId>javax.activation</groupId>
      <artifactId>activation</artifactId>
      <debian>libgnujav-java</debian>
      <redhat>sun-jaf</redhat>
    </dependency>
  </mapping>
  <!-- Excluding due to Geronimo Dependency Requirements -->
  <project groupId="org.eclipse.jetty">
    <exclude>jetty-annotations</exclude>
    <exclude>jetty-jaspi</exclude>
    <exclude>jetty-plus</exclude>
  </project>
  <!-- Dependencies for OSGI are too complicated to deal with right now -->
  <project groupId="org.eclipse.jetty.osgi">
    <exclude>jetty-osgi</exclude>
    <exclude>jetty-osgi-boot</exclude>
    <exclude>jetty-osgi-boot-jsp</exclude>
    <exclude>jetty-osgi-boot-logback</exclude>
    <exclude>jetty-osgi-boot-warurl</exclude>
    <exclude>jetty-httpservice</exclude>
  </project>
  <!-- Aggregate Projects need not be built by linux-packaging -->
  <project groupId="org.eclipse.jetty.aggregate">
    <exclude>jetty-server</exclude>
    <exclude>jetty-client</exclude>
    <exclude>jetty-servlet</exclude>
    <exclude>jetty-webapp</exclude>
    <exclude>jetty-plus</exclude>
    <exclude>jetty-all-server</exclude>
    <exclude>jetty-all</exclude>
  </project>
  <daemon>
    <script>jetty-distribution/src/main/resources/bin/jetty.sh</script>
    <debian>debian/jetty.init</debian>
    <redhat>rpm/jetty.init</redhat>
  </daemon>
</linux-packaging>
Something went wrong with that request. Please try again.