Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

All releases will now be signed. See "Installation" in the readme.

  • Loading branch information...
commit 083ef722aa9c62978448e9720a8d89e8993dd475 1 parent fae7b21
@delano authored
View
4 CHANGES.txt
@@ -1,8 +1,10 @@
RYE, CHANGES
-#### 0.9.8 (2013-01-??) #############################
+#### 0.9.8 (2013-02-06) #############################
* ADDED: Rudimentary DSL (see tst/dsl_example.rb) [Randy D. Wallace Jr]
+* CHANGE: All releases will now be signed. See "Installation" in the readme.
+
#### 0.9.7 (2012-07-06) #############################
View
35 Rakefile
@@ -8,28 +8,29 @@ CLEAN.include [ 'pkg', 'rdoc' ]
name = "rye"
$:.unshift File.join(File.dirname(__FILE__), 'lib')
-puts $:
require name
-
version = Rye::VERSION.to_s
begin
require "jeweler"
- Jeweler::Tasks.new do |gem|
- gem.version = version
- gem.name = name
- gem.rubyforge_project = gem.name
- gem.summary = "Run SSH commands on a bunch of machines at the same time (from Ruby)."
- gem.description = "Run SSH commands on a bunch of machines at the same time (from Ruby)."
- gem.email = "delano@solutious.com"
- gem.homepage = "https://github.com/delano/rye"
- gem.authors = ["Delano Mandelbaum"]
- gem.add_dependency 'annoy'
- gem.add_dependency 'sysinfo', '>= 0.7.3'
- gem.add_dependency 'highline', '>= 1.5.1'
- gem.add_dependency 'net-ssh', '>= 2.0.13'
- gem.add_dependency 'net-scp', '>= 1.0.2'
- gem.add_dependency 'docile', '>= 1.0.1'
+ Jeweler::Tasks.new do |s|
+ s.version = version
+ s.name = name
+ s.rubyforge_project = s.name
+ s.summary = "Run SSH commands on a bunch of machines at the same time (from Ruby)."
+ s.description = "Run SSH commands on a bunch of machines at the same time (from Ruby)."
+ s.email = "delano@solutious.com"
+ s.homepage = "https://github.com/delano/rye"
+ s.authors = ["Delano Mandelbaum"]
+ s.add_dependency 'annoy'
+ s.add_dependency 'sysinfo', '>= 0.7.3'
+ s.add_dependency 'highline', '>= 1.5.1'
+ s.add_dependency 'net-ssh', '>= 2.0.13'
+ s.add_dependency 'net-scp', '>= 1.0.2'
+ s.add_dependency 'docile', '>= 1.0.1'
+
+ s.signing_key = File.join('/mnt/gem/', 'gem-private_key.pem')
+ s.cert_chain = ['gem-public_cert.pem']
end
Jeweler::GemcutterTasks.new
rescue LoadError
View
2  VERSION
@@ -1 +1 @@
-0.9.7
+0.9.8
View
20 gem-public_cert.pem
@@ -0,0 +1,20 @@
+-----BEGIN CERTIFICATE-----
+MIIDNjCCAh6gAwIBAgIBADANBgkqhkiG9w0BAQUFADBBMQ8wDQYDVQQDDAZkZWxh
+bm8xGTAXBgoJkiaJk/IsZAEZFglzb2x1dGlvdXMxEzARBgoJkiaJk/IsZAEZFgNj
+b20wHhcNMTMwMjA2MTE1NzQ1WhcNMTQwMjA2MTE1NzQ1WjBBMQ8wDQYDVQQDDAZk
+ZWxhbm8xGTAXBgoJkiaJk/IsZAEZFglzb2x1dGlvdXMxEzARBgoJkiaJk/IsZAEZ
+FgNjb20wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQDg1hMtl0XsMuUK
+AKTgYWv3gjj7vuEsE2EjT+vyBg8/LpqVVwZziiaebJT9IZiQ+sCFqbiakj0b53pI
+hg1yOaBEmH6/W0L7rwzqaRV9sW1eJs9JxFYQCnd67zUnzj8nnRlOjG+hhIG+Vsij
+npsGbt28pefuNZJjO5q2clAlfSniIIHfIsU7/StEYu6FUGOjnwryZ0r5yJlr9RrE
+Gs+q0DW8QnZ9UpAfuDFQZuIqeKQFFLE7nMmCGaA+0BN1nLl3fVHNbLHq7Avk8+Z+
+ZuuvkdscbHlO/l+3xCNQ5nUnHwq0ADAbMLOlmiYYzqXoWLjmeI6me/clktJCfN2R
+oZG3UQvvAgMBAAGjOTA3MAkGA1UdEwQCMAAwHQYDVR0OBBYEFMSJOEtHzE4l0azv
+M0JK0kKNToK1MAsGA1UdDwQEAwIEsDANBgkqhkiG9w0BAQUFAAOCAQEAtOdE73qx
+OH2ydi9oT2hS5f9G0y1Z70Tlwh+VGExyfxzVE9XwC+iPpJxNraiHYgF/9/oky7ZZ
+R9q0/tJneuhAenZdiQkX7oi4O3v9wRS6YHoWBxMPFKVRLNTzvVJsbmfpCAlp5/5g
+ps4wQFy5mibElGVlOobf/ghqZ25HS9J6kd0/C/ry0AUtTogsL7TxGwT4kbCx63ub
+3vywEEhsJUzfd97GCABmtQfRTldX/j7F1z/5wd8p+hfdox1iibds9ZtfaZA3KzKn
+kchWN9B6zg9r1XMQ8BM2Jz0XoPanPe354+lWwjpkRKbFow/ZbQHcCLCq24+N6b6g
+dgKfNDzwiDpqCA==
+-----END CERTIFICATE-----
View
5 rye.gemspec
@@ -5,10 +5,11 @@
Gem::Specification.new do |s|
s.name = "rye"
- s.version = "0.9.7"
+ s.version = "0.9.8"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Delano Mandelbaum"]
+ s.cert_chain = ["gem-public_cert.pem"]
s.date = "2013-02-06"
s.description = "Run SSH commands on a bunch of machines at the same time (from Ruby)."
s.email = "delano@solutious.com"
@@ -23,6 +24,7 @@ Gem::Specification.new do |s|
"Rakefile",
"Rudyfile",
"VERSION",
+ "gem-public_cert.pem",
"lib/esc.rb",
"lib/rye.rb",
"lib/rye/box.rb",
@@ -66,6 +68,7 @@ Gem::Specification.new do |s|
s.require_paths = ["lib"]
s.rubyforge_project = "rye"
s.rubygems_version = "1.8.25"
+ s.signing_key = "/mnt/gem/gem-private_key.pem"
s.summary = "Run SSH commands on a bunch of machines at the same time (from Ruby)."
if s.respond_to? :specification_version then
Please sign in to comment.
Something went wrong with that request. Please try again.