Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Release 0.6.3

NOTE: command testing (:cli) is still disabled.

* FIXED: Now correctly append to existing Tryouts object
* CHANGE: Renamed :regex format to :match
* ADDED: Hella better runtime error handling
* ADDED: Better support for quiet (-q)
* ADDED: Verbose output now displays each dream vs reality
* ADDED: Skipped drills now appear in the report
* ADDED: new dream format: :ne (!=)

                       __-------_
                      -   -ooooooo
                     |   |         o
                    |   |           o
                    |   |           o
                    |   /           o
                    |  | o         o
                    |  |   ooooooo
                    |   |
                    |   |
                    |   |               __________________________
                   |    |              |__________________________|
                   |    |               \/\/\/\/\/\/\/\/\/\/\/\/\/
                   |    |                \/\/\/\/\/\/\/\/\/\/\/\/
            __-----|    |                 \/\/\/\/\/\/\/\/\/\/\/
           /      /      |                 \/\/\/\/\/\/\/\/\/\/
           |     |       |                  |/\/\/\/\/\/\/\/\|
           |   _/        |                   |/\/\/\/\/\/\/\|
           | _/           \                  |\/\/\/\/\/\/\/|
           _/              \                 |/\/\/\/\/\/\\/|
       |                    |
      /|                    /
     |  \                  |
     |   \                /
    /    /\              |
   |    |  \             |
   |    |   |            |
   |   |     \          |
   |   |      |         |
   \   |       |________|
    |  |      |_________|
    |  |     |           |
____|  |    |             |
\_____/     |             |
           |              |
           |    |         |
           |    |        |
            |   |        |
             |_|_______|
              | /     |
              ||      |
              ||      |
              | |    |
              ||      |
              ||     |
              ||     |
              |     |
              |    |
              ||  |
              ||__|
             | /  |
             ||___||
             |\   \ |
             | \   \|
              \ \__\
               |__/
  • Loading branch information...
commit 9401711eebcf1fa66b89509430415cad196e713f 1 parent 28233af
@delano authored
View
4 CHANGES.txt
@@ -1,7 +1,7 @@
TRYOUTS, CHANGES
-#### 0.6.3 (2009-06-24) ###############################
+#### 0.6.3 (2009-06-25) ###############################
NOTE: command testing (:cli) is still disabled.
@@ -11,7 +11,7 @@ NOTE: command testing (:cli) is still disabled.
* ADDED: Better support for quiet (-q)
* ADDED: Verbose output now displays each dream vs reality
* ADDED: Skipped drills now appear in the report
-* ADDED: != dream format: :ne
+* ADDED: new dream format: :ne (!=)
#### 0.6.2 (2009-06-24) ###############################
View
2  lib/tryouts.rb
@@ -32,7 +32,7 @@ class Exception < RuntimeError; end
# Raised when there is a problem loading or parsing a Tryouts::Drill::Dream object
class BadDreams < Exception; end
- VERSION = "0.6.2"
+ VERSION = "0.6.3"
require 'tryouts/mixins'
require 'tryouts/tryout'
View
2  lib/tryouts/tryout.rb
@@ -79,7 +79,7 @@ def run
if dream != drill.reality
puts '%6s%s'.color(c) % ['', drill.reality.output.inspect]
else
- puts '%6s%s'.color(c) % ["", dream.test_to_string(drill.reality)]
+ puts '%6s%s'.color(:green) % ["", dream.test_to_string(drill.reality)]
end
end
end
View
10 tryouts.gemspec
@@ -1,7 +1,7 @@
@spec = Gem::Specification.new do |s|
s.name = "tryouts"
s.rubyforge_project = "tryouts"
- s.version = "0.6.2"
+ s.version = "0.6.3"
s.summary = "Tryouts are high-level tests for your Ruby code. May all your dreams come true!"
s.description = s.summary
s.author = "Delano Mandelbaum"
@@ -24,8 +24,8 @@
# = DEPENDENCIES =
# Add all gem dependencies
- s.add_dependency 'drydock', '>= 0.6.5'
s.add_dependency 'rye', '>= 0.8.2'
+ s.add_dependency 'drydock', '>= 0.6.6'
s.add_dependency 'sysinfo', '>= 0.5.1'
# = MANIFEST =
@@ -64,12 +64,12 @@
s.specification_version = 2
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_runtime_dependency(%q<RedCloth>, [">= 4.0.4"])
+ #s.add_runtime_dependency(%q<RedCloth>, [">= 4.0.4"])
else
- s.add_dependency(%q<RedCloth>, [">= 4.0.4"])
+ #s.add_dependency(%q<RedCloth>, [">= 4.0.4"])
end
else
- s.add_dependency(%q<RedCloth>, [">= 4.0.4"])
+ #s.add_dependency(%q<RedCloth>, [">= 4.0.4"])
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.