Permalink
Browse files

Moved the dependency into the spec and set it to <= 2.1.0.

  • Loading branch information...
delynn committed Aug 10, 2009
1 parent 7d890c2 commit 14397e56ff78148aecc34c8d2986c0e65e606a1a
Showing with 2 additions and 9 deletions.
  1. +2 −2 Rakefile
  2. +0 −7 lib/uuid_fu/uuid_fu.rb
View
@@ -15,7 +15,7 @@ end
@gem_spec = Gem::Specification.new do |s|
s.name = "uuid_fu"
- s.version = "1.0.3"
+ s.version = "1.0.4"
s.summary = "A gem that helps out with using UUIDs for primary keys in ActiveRecord objects."
s.description = "Developed by: delynn@gmail.com"
s.author = "DeLynn Berry"
@@ -30,13 +30,13 @@ end
#s.bindir = "bin"
#s.executables << "uuid_fu"
#s.add_dependency("", "")
- #s.add_dependency("", "")
#s.extensions << ""
#s.required_ruby_version = ">= 1.8.6"
#s.default_executable = ""
#s.platform = "Gem::Platform::Ruby"
#s.requirements << "An ice cold beer."
#s.requirements << "Some free time!"
+ s.add_dependency("assaf-uuid", "<=2.1.0")
end
# rake package
View
@@ -1,10 +1,3 @@
-begin
- gem 'assaf-uuid', '=2.0.1'
- require 'uuid'
-rescue Gem::LoadError
- raise "This plug-in is only compatible with version 2.0.1 of the following UUID gem: http://github.com/assaf/uuid"
-end
-
module UuidFu
def self.included(base)
base.extend(ClassMethods)

0 comments on commit 14397e5

Please sign in to comment.