Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot build site due to dependency error (11ty) #1324

Closed
1 task done
parthmshah1302 opened this issue Sep 11, 2021 · 3 comments
Closed
1 task done

Cannot build site due to dependency error (11ty) #1324

parthmshah1302 opened this issue Sep 11, 2021 · 3 comments
Labels
scope.publish Static site generation, sending note links and anything to do with publishing your notes. type.bug Something isn't working
Milestone

Comments

@parthmshah1302
Copy link

  • Publish. Sharing your repo with the world

Describe the bug

Dependency error of 11ty on siteBuild.

To Reproduce

Steps to reproduce the behavior:

  1. Dendron: Site Build

Expected behavior

Site is built at x location.

Screenshots

image

Desktop (please complete the following information)

  • OS: Windows 10
  • Browser: Chrome

Additional context

Add any other context about the problem here.

Dendron Log file

dendron.log

@github-actions github-actions bot added scope.publish Static site generation, sending note links and anything to do with publishing your notes. status.triage-needed type.bug Something isn't working labels Sep 11, 2021
@kevinslin
Copy link
Member

thanks for the report. this should now be fixed with 0.58.3

@kevinslin kevinslin added the status.info-needed More information is needed from filer for issue to be actionable label Sep 13, 2021
@kevinslin kevinslin added this to the v58 milestone Sep 13, 2021
@parthmshah1302
Copy link
Author

Hey Kevin!
I am still facing the issue

error running command: Command failed with exit code 4294963248: npm install --save @dendronhq/dendron-11ty@1.58.4
npm ERR! code EPERM
npm ERR! syscall rmdir
npm ERR! path c:\Users\parth\Desktop\Code\Notes\node_modules\.staging\get-stream-90b62ddd
npm ERR! errno -4048
npm ERR! Error: EPERM: operation not permitted, rmdir 'c:\Users\parth\Desktop\Code\Notes\node_modules\.staging\get-stream-90b62ddd'
npm ERR!  [Error: EPERM: operation not permitted, rmdir 'c:\Users\parth\Desktop\Code\Notes\node_modules\.staging\get-stream-90b62ddd'] {
npm ERR!   errno: -4048,
npm ERR!   code: 'EPERM',
npm ERR!   syscall: 'rmdir',
npm ERR!   path: 'c:\\Users\\parth\\Desktop\\Code\\Notes\\node_modules\\.staging\\get-stream-90b62ddd'
npm ERR! }
npm ERR! 
npm ERR! The operation was rejected by your operating system.
npm ERR! It's possible that the file was already in use (by a text editor or antivirus),
npm ERR! or that you lack permissions to access it.
npm ERR! 
npm ERR! If you believe this might be a permissions issue, please double-check the
npm ERR! permissions of the file and its containing directories, or try running
npm ERR! the command again as root/Administrator.

I am pretty sure this is not a permissions issue.
The log file can be found here

2021-09-13T16_17_16_020Z-debug.log

@no-response no-response bot removed the status.info-needed More information is needed from filer for issue to be actionable label Sep 13, 2021
@kevinslin
Copy link
Member

We had a regression with the last 11ty publishing. Can you update to the latest version of the CLI and 11ty by following the setup instructions here?

@kevinslin kevinslin modified the milestones: v58, v61 Sep 20, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
scope.publish Static site generation, sending note links and anything to do with publishing your notes. type.bug Something isn't working
Projects
None yet
Development

No branches or pull requests

3 participants