New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Make Traute work with gradle apt plugin #88

Closed
denis-zhdanov opened this Issue Jan 2, 2018 · 1 comment

Comments

Projects
None yet
1 participant
@denis-zhdanov
Owner

denis-zhdanov commented Jan 2, 2018

When apt plugin is configured for the target Gradle project, Traute instrumentations are not applied.

The problem is that the apt plugin overwrites annotation processors config regardless of it's existing non-empty state.

@denis-zhdanov denis-zhdanov self-assigned this Jan 2, 2018

denis-zhdanov added a commit that referenced this issue Jan 2, 2018

@denis-zhdanov

This comment has been minimized.

Owner

denis-zhdanov commented Jan 2, 2018

Traute now puts its settings into apt plugin's configs (if any)

denis-zhdanov added a commit that referenced this issue Jan 2, 2018

Issue #88: Make Traute work with gradle apt plugin
Avoid throwing/catching exceptions for a project with
many files generated by annotation processors
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment