Skip to content
Deno Binary Installer
Branch: master
Clone or download

README.md

deno_install

One-line commands to install Deno on your system.

Linux & Mac Windows
Build Status Build status

Install Latest Version

With Shell:

curl -fsSL https://deno.land/x/install/install.sh | sh

With PowerShell:

iwr https://deno.land/x/install/install.ps1 -useb | iex

Install Specific Version

With Shell:

curl -fsSL https://deno.land/x/install/install.sh | sh -s v0.2.10

With PowerShell:

iwr https://deno.land/x/install/install.ps1 -useb -outf install.ps1; .\install.ps1 v0.2.10

Install via Package Manager

With Scoop:

scoop install deno

With Homebrew:

brew install deno

Compatibility

Known Issues

Could not create SSL/TLS secure channel

PS C:\> iwr https://deno.land/x/install/install.ps1 -useb | iex
iwr : The request was aborted: Could not create SSL/TLS secure channel.
At line:1 char:1
+ iwr https://deno.land/x/install/install.ps1 -useb | iex
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-WebRequest], WebException
    + FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeWebRequestCommand

When does this issue occur?

If your systems' ServicePointManager is configured to use an out-dated security protocol, such as, TLS 1.0.

How can this issue be fixed?

Configure your system to use an up-to-date security protocol, such as, TLS 1.2:

[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12

Running scripts is disabled

PS C:\> iwr https://deno.land/x/install/install.ps1 -useb -outf install.ps1; .\install.ps1 v0.2.10
.\install.ps1 : File C:\install.ps1 cannot be loaded because running scripts is disabled on this system. For more information, see about_Execution_Policies at https:/go.microsoft.com/fwlink/?LinkID=135170.
At line:1 char:71
+ ... /x/install/install.ps1 -useb -outf install.ps1; .\install.ps1 v0.2.10
+                                                     ~~~~~~~~~~~~~
    + CategoryInfo          : SecurityError: (:) [], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : UnauthorizedAccess

When does this issue occur?

If your systems' ExecutionPolicy is Undefined or Restricted.

How can this issue be fixed?

Allow scripts that are downloaded from the internet to be executed by setting the execution policy to RemoteSigned:

Set-ExecutionPolicy RemoteSigned -Scope CurrentUser -Force
You can’t perform that action at this time.