Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[WebSocket] Add sec-websocket-version to handshake header #468

Merged
merged 1 commit into from May 30, 2019

Conversation

2 participants
@hashrock
Copy link
Contributor

commented May 30, 2019

I tried to communicate with deno_std WebSocket Client and a WebSocket Endpoint of Chrome DevTools, but handshake was rejected by Chrome.

I had to add a sec-websocket-version field to the request header to fix this.

According to the RFC, sec-websocket-version is required for the WebSocket Client implementation.

The request MUST include a header field with the name |Sec-WebSocket-Version|. The value of this header field MUST be 13.

https://tools.ietf.org/html/rfc6455#page-60

cc: @keroxp

@ry

ry approved these changes May 30, 2019

Copy link
Contributor

left a comment

LGTM

@ry ry merged commit 40f55da into denoland:master May 30, 2019

5 checks passed

denoland.deno_std Build #20190530.11 succeeded
Details
denoland.deno_std (Linux) Linux succeeded
Details
denoland.deno_std (Mac) Mac succeeded
Details
denoland.deno_std (Windows) Windows succeeded
Details
license/cla Contributor License Agreement is signed.
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.