New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Show/Hide animations on Empties not being exported (3.5.0-beta2) #377

Closed
dpospisil opened this Issue Aug 23, 2018 · 3 comments

Comments

Projects
None yet
2 participants
@dpospisil

dpospisil commented Aug 23, 2018

Show/Hide animations used to be exported when applied on empties. Whis way it was possible to apply show/hide property on a whole hierarchy of objects.

With 3.5.0-beta2 the Show/Hide animations seem to be ignored on empties.

tngreene added a commit that referenced this issue Aug 23, 2018

@tngreene

This comment has been minimized.

Collaborator

tngreene commented Aug 23, 2018

Quick to debug:

When overriding XPlaneObject.collect, I did not include a call to super().collect()

class XPlaneEmpty(XPlaneObject):
...
    def collect(self):
        super().collect()
        return

By forgetting the call to super().collect() we never collect show/hide animations.

Fixed with 081ab9d

@tngreene tngreene closed this Aug 23, 2018

@tngreene

This comment has been minimized.

Collaborator

tngreene commented Aug 23, 2018

Try this build out, see if it works for you too. io_xplane2blender_3_5_0-dev_0-32_20180823200034.zip

@dpospisil

This comment has been minimized.

dpospisil commented Aug 24, 2018

Verified, works as expected. Many thanks for quick fix!!!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment