Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

ERROR: While generating documentation for mongo3-0.1.3 #12

Open
gr opened this Issue · 2 comments

3 participants

@gr
gr commented

george@gregentov:~$ gem install mongo3
WARNING: RubyGems 1.2+ index not found for:

RubyGems will revert to legacy indexes degrading performance.
Updating metadata for 1 gems from http://rubygems.org/
.
complete
Updating metadata for 1 gems from http://rubygems.org/
.
complete
ERROR: While executing gem ... (Gem::FilePermissionError)
You don't have write permissions into the /var/lib/gems/1.8 directory.
george@gregentov:~$ sudo gem install mongo3
Building native extensions. This could take a while...
Building native extensions. This could take a while...
Building native extensions. This could take a while...
Successfully installed bson-1.2.0
Successfully installed mongo-1.2.0
Successfully installed bson_ext-1.2.0
Successfully installed agnostic-will_paginate-3.0.0
Successfully installed memcache-client-1.8.5
Successfully installed rack-1.2.1
Successfully installed mongo_ext-0.19.3
Successfully installed mongo_rack-0.0.5
Successfully installed fattr-2.2.0
Successfully installed arrayfields-4.7.4
Successfully installed main-4.4.0
Successfully installed json-1.5.1
Successfully installed tilt-1.2.2
Successfully installed sinatra-1.1.2
Successfully installed mongo3-0.1.3
15 gems installed
Installing ri documentation for bson-1.2.0...
Installing ri documentation for mongo-1.2.0...
Installing ri documentation for bson_ext-1.2.0...

No definition for method_serialize

No definition for method_deserialize

No definition for method_max_bson_size

No definition for method_update_max_bson_size
Installing ri documentation for agnostic-will_paginate-3.0.0...
Installing ri documentation for memcache-client-1.8.5...
Installing ri documentation for rack-1.2.1...
Installing ri documentation for mongo_ext-0.19.3...

No definition for method_serialize

No definition for method_deserialize

No definition for fast_pack
Installing ri documentation for mongo_rack-0.0.5...
Installing ri documentation for fattr-2.2.0...
Installing ri documentation for arrayfields-4.7.4...
Installing ri documentation for main-4.4.0...
Installing ri documentation for json-1.5.1...
Installing ri documentation for tilt-1.2.2...
Installing ri documentation for sinatra-1.1.2...
Installing ri documentation for mongo3-0.1.3...
Installing RDoc documentation for bson-1.2.0...
Installing RDoc documentation for mongo-1.2.0...
Installing RDoc documentation for bson_ext-1.2.0...

No definition for method_serialize

No definition for method_deserialize

No definition for method_max_bson_size

No definition for method_update_max_bson_size
Installing RDoc documentation for agnostic-will_paginate-3.0.0...
Installing RDoc documentation for memcache-client-1.8.5...
Installing RDoc documentation for rack-1.2.1...
Installing RDoc documentation for mongo_ext-0.19.3...

No definition for method_serialize

No definition for method_deserialize

No definition for fast_pack
Installing RDoc documentation for mongo_rack-0.0.5...
Installing RDoc documentation for fattr-2.2.0...
Installing RDoc documentation for arrayfields-4.7.4...
Installing RDoc documentation for main-4.4.0...
Installing RDoc documentation for json-1.5.1...
Installing RDoc documentation for tilt-1.2.2...
Installing RDoc documentation for sinatra-1.1.2...
Installing RDoc documentation for mongo3-0.1.3...
ERROR: While generating documentation for mongo3-0.1.3
... MESSAGE: Unhandled special: Special: type=17, text="<!-- -->"
... RDOC args: --op /var/lib/gems/1.8/doc/mongo3-0.1.3/rdoc --main README.rdoc --quiet lib lib/views/collections/_fields_form.erb lib/views/collections/_index_form.erb lib/views/collections/_index_rows.erb lib/views/collections/_indexes.erb lib/views/collections/_nodes.erb lib/views/collections/_results.erb lib/views/collections/_rows_table.erb lib/views/collections/_rows_tree.erb lib/views/collections/_search_form.erb lib/views/collections/all_done.js.erb lib/views/collections/list.erb lib/views/collections/results.js.erb lib/views/collections/update.js.erb lib/views/collections/update_indexes.js.erb lib/views/databases/_results.erb lib/views/databases/list.erb lib/views/databases/results.js.erb lib/views/explore/_crumbs.erb lib/views/explore/_dump_array.erb lib/views/explore/_dump_hash.erb lib/views/explore/_info.erb lib/views/explore/_node_info.erb lib/views/explore/center_js.erb lib/views/explore/explore.erb lib/views/explore/load_collection.js.erb lib/views/explore/load_database.js.erb lib/views/explore/more_data_js.erb lib/views/explore/update.js.erb lib/views/explore/update_crumb_js.erb lib/views/landscape.erb lib/views/layout.erb lib/views/shared/_flash.erb lib/views/shared/flash.js.erb lib/views/users/_new.erb lib/views/users/_results.erb lib/views/users/list.erb lib/views/users/results.js.erb --title mongo3-0.1.3 Documentation
(continuing with the rest of the installation)

george@gregentov:~$ mongo
mongo mongod mongodump mongoexport mongofiles mongoimport mongorestore mongos mongostat

george@gregentov:~$ mongo3
Команда 'mongo3' не найдена, возможно вы имели в виду:
Команда 'mongo' из пакета 'mongodb-clients' (universe)
Команда 'mongod' из пакета 'mongodb-server' (universe)
Команда 'mongos' из пакета 'mongodb-server' (universe)
mongo3: команда не найдена
error localization: there is no mongo3 package, maybe you want mongo/mongod/mongos

@fredbaa

i also get this error. how do you fix this?

@jasper1

i also get this error. WTF?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.