BSON dependencies collide with mongodb #23

Open
johnjohndoe opened this Issue Apr 29, 2012 · 2 comments

3 participants

@johnjohndoe

I realized there is a problem running mongo3 when mongodb has been installed as follows on Ubuntu 10.10.

sudo apt-get install mongodb

I did not manage to compile mongodb from the sources as stated here. Therefore, the installation of mongodb depends on bson 1.5.2. However, mongo3 seems to require bson >= 1.6.0. When I start the application the following error is printed to the console.

$ mongo3                            
/home/USER/.rvm/rubies/ruby-1.9.3-p125/lib/ruby/site_ruby/1.9.1/rubygems/specification.rb:774:in 
    `block in activate_dependencies': can't satisfy 'bson (>= 1.6.0)', 
    already activated 'bson-1.5.2' (Gem::LoadError)
[...]

Can you describe a way to encapsulate the bson gems for mongodb and mongo3?

@songrit

me too

@sdbondi

Any solution for this?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment