Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Unable to start mongo3: no such file to load -- mongo/util/ordered_hash #9

Open
misaka opened this Issue May 31, 2010 · 0 comments

Comments

Projects
None yet
1 participant

misaka commented May 31, 2010

Installed mongo3 with rvm (v.0.1.2) and using Ruby 1.8.7 ... I get this when I try to start mongo3, even without a landscape.yml file:

% mongo3
F, [2010-05-31T10:29:08.886560 #14607] FATAL -- : no such file to load -- mongo/util/ordered_hash (LoadError)
/home/misaka/.rvm/rubies/ruby-1.8.7-p249/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
/home/misaka/.rvm/rubies/ruby-1.8.7-p249/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/mongo3-0.1.2/lib/mongo3/node.rb:2
/home/misaka/.rvm/rubies/ruby-1.8.7-p249/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
/home/misaka/.rvm/rubies/ruby-1.8.7-p249/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/mongo3-0.1.2/lib/mongo3.rb:41:in `require_all_libs_relative_to'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/mongo3-0.1.2/lib/mongo3.rb:41:in `each'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/mongo3-0.1.2/lib/mongo3.rb:41:in `require_all_libs_relative_to'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/mongo3-0.1.2/lib/mongo3.rb:53
/home/misaka/.rvm/rubies/ruby-1.8.7-p249/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
/home/misaka/.rvm/rubies/ruby-1.8.7-p249/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in `require'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/mongo3-0.1.2/bin/mongo3:20:in `run!'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/main-4.2.0/lib/main/program/class_methods.rb:147:in `run'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/main-4.2.0/lib/main/program/class_methods.rb:136:in `catch'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/main-4.2.0/lib/main/program/class_methods.rb:136:in `run'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/main-4.2.0/lib/main/factories.rb:18:in `run'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/main-4.2.0/lib/main/factories.rb:25:in `Main'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/gems/mongo3-0.1.2/bin/mongo3:7
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/bin/mongo3:19:in `load'
/home/misaka/.rvm/gems/ruby-1.8.7-p249@mongo3/bin/mongo3:19

Looking at the mongo gem that's installed (v1.0.1) I only see these files in lib/mongo/util:

lib/mongo/util/conversions.rb
lib/mongo/util/core_ext.rb
lib/mongo/util/server_version.rb
lib/mongo/util/support.rb
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment