Rails code running the Lobsters link aggregation site
Clone or download
Pull request Compare This branch is 10 commits ahead, 867 commits behind lobsters:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
app
bin
config
db
extras
lib
public
script
spec
vendor
.gitignore
.rspec
.ruby-version
CONTRIBUTING.md
Gemfile
Gemfile.lock
LICENSE
README.md
Rakefile
config.ru

README.md

Lobsters Rails Project

This is a slightly-modified version of the source code to the site operating at https://lobste.rs. It has been modified to make it easier to set up for the purposes of the Keep Rails Upgraded workshop being held at RailsConf 2016.

Most notably, the dependencies have been simplified and the application has been updated to run on and require Ruby 2.2+. Site search will not function with our simplified dependencies, but that is not necessary for our workshop.

Getting Set Up

Prior to the workshop, you should:

  1. Have Ruby 2.3 installed
  2. Clone this repository locally with: git clone git@github.com/derekprior/lobsters
  3. From the lobsters directory, run bin/setup
  4. Verify the test suite passes with bundle exec rake

Troublshooting

If you have trouble setting the application up or you find any of this confusing, please open an issue with as much detail as possible including any stack traces and error messages.