Skip to content

0.20.29 - Dark Energy (hotfix #3)

Compare
Choose a tag to compare
@derrod derrod released this 16 Sep 11:28
· 19 commits to master since this release

This is another hotfix release for Legendary, that fixes downloading of manifests not working sometimes due to Epic breaking their CDN for some reason, as well as some other minor fixes that have been made since the last release.

As always you can support Legendary development via Ko-Fi or by purchasing CrossOver through my affiliate link

Changes

  • Try all manifest URLs until one works (#477, thanks @CommandMC)
  • Workaround GraphQL not working with newer EGL user agent (#474)
  • Fix some potential zero division error in file verification by using high-precision timers (thanks @loathingKernel for the suggestion)
  • Added separate .deb file built for Ubuntu 22.04 and later that includes webview login (untested)