Installation

derv82 edited this page Feb 19, 2012 · 12 revisions
Clone this wiki locally

Guide for installing Wifite's required programs in Backtrack 5 R1, Ubuntu 11/10, and Debian 6.

Wifite absolutely requires the aircrack-ng suite. However, these other programs can enhance your experience.

Reaver is required for attacking WPS-enabled networks.

Tshark, Pyrit and Cowpatty are only useful as extra checks for validating WPA handshakes. They are non-essential.

aircrack-ng 1.1

Aircrack-ng is a suite of tools designed to attack and exploit wireless networks. This suite has everything required to audit, attack, and crack WEP- and WPA-encrypted access points.

You can install aircrack-ng using apt-get on Backtrack, Ubuntu, and BlackBuntu repositories.

sudo apt-get install aircrack-ng

Add universe/multiverse in sources.lst if needed. (how to add universe and multiverse)

If this option is unavailable, you can install aircrack-ng from source via the project homepage, or using the commands below:

wget http://download.aircrack-ng.org/aircrack-ng-1.1.tar.gz
tar -zxvf aircrack-ng-1.1.tar.gz
cd aircrack-ng-1.1
make
sudo make install

Many attacks require wireless drivers that have been patched to allow packet injection. On top of this, not all wireless devices are compatible with aircrack-ng. You can see the install_drivers page on aircrack-ng's site for more information.

reaver 1.4 & wash/walsh

Reaver is a tool which attacks WPS (Wifi-Protected Setup) networks. "Wash" (or "Walsh") is a WPS scanning tool that comes bundled with Reaver.

Reaver 1.4 is on the (updated) Backtrack 5 repositories and can be installed by using:

apt-get update
apt-get install reaver

If this option is unavailable, you can install reaver 1.4 from source via the project homepage, or using these commands:

wget http://reaver-wps.googlecode.com/files/reaver-1.4.tar.gz
tar zxvf reaver-1.4.tar.gz
cd reaver-1.4
cd src
./configure

If configure complains about libpcap (error: pcap library not found!), use:

sudo apt-get install libpcap0.8-dev libsqlite3-dev

LibSqlite3 is also required, but the configure does not throw a warning if it isn't found; it throws the same pcap library not found warning (this is a bug in the configure).

./configure (again, and look for errors)

If you didn't get any errors:

make
sudo make install

tshark 1.6.2

TShark is a text-based packet analyzer that comes bundled with Wireshark.

sudo apt-get install tshark

pyrit 0.4

Pyrit is a GPU-based WPA PSK cracker.

Pyrit is available on some repositories (such as Backtrack's):

sudo apt-get install pyrit

If this option is unavailable, you can install the project from source via the project homepage, or using the commands below.

Pyrit requires the python-dev, libssl-dev and scapy libraries. You can install these using:

sudo apt-get install libssl-dev scapy python-dev

To download/extract/build Pyrit:

wget http://pyrit.googlecode.com/files/pyrit-0.4.0.tar.gz
tar zxvf pyrit-0.4.0.tar.gz
cd pyrit-0.4.0
python setup.py build

If there are no errors, install Pyrit using:

python setup.py install

cowpatty 4.6

Cowpatty is a WPA PSK cracker.

Cowpatty comes standard on Backtrack5 and is available on the repositories:

sudo apt-get install cowpatty

If this option is unavailable, you can install from source via the project homepage, or using the commands below.

Cowpatty requires the libssl-dev library:

sudo apt-get install libssl-dev

To download and install cowpatty, type:

wget http://wirelessdefence.org/Contents/Files/cowpatty-4.6.tgz
tar -xvf cowpatty-4.6.tgz
cd cowpatty-4.6
make
sudo make install