Permalink
Browse files

js : use $.event.dispatch

.handle was making jQuery Migrate whiny

tick version
  • Loading branch information...
1 parent 19eb6fd commit 07a349867efb698302be6623e2f67bba0ae424b5 @desandro committed Feb 8, 2013
Showing with 5 additions and 6 deletions.
  1. +1 −1 _posts/docs/2011-05-01-intro.mdown
  2. +2 −3 jquery.masonry.js
  3. +2 −2 jquery.masonry.min.js
@@ -33,7 +33,7 @@ Masonry works on a container element with a group of similar child items.
{% endhighlight %}
-Add jQuery and the Masonry script. Masonry requires jQuery v1.4.0 and greater.
+Add jQuery and the Masonry script. Masonry requires jQuery v1.5 and greater.
{% highlight html %}
View
@@ -1,5 +1,5 @@
/**
- * jQuery Masonry v2.1.07
+ * jQuery Masonry v2.1.08
* A dynamic layout plugin for jQuery
* The flip-side of CSS Floats
* http://masonry.desandro.com
@@ -26,7 +26,6 @@
*/
var $event = $.event,
- dispatchMethod = $.event.handle ? 'handle' : 'dispatch',
resizeTimeout;
$event.special.smartresize = {
@@ -46,7 +45,7 @@
if ( resizeTimeout ) { clearTimeout( resizeTimeout ); }
resizeTimeout = setTimeout(function() {
- $event[ dispatchMethod ].apply( context, args );
+ $event.dispatch.apply( context, args );
}, execAsap === "execAsap"? 0 : 100 );
}
View

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.

2 comments on commit 07a3498

I´m getting a problem with this changes in chrome and firefox and jQuery version "1.5.2". On http://masonry.desandro.com/docs/intro.html that "Masonry requires jQuery v1.5 and greater". Do you not support jQuery version 1.5 anymore or is that an mistake?

Owner

desandro replied Mar 11, 2013

No jQuery 1.5 is no longer supported. I'll submit a new issue to change this #313

Please sign in to comment.