Skip to content

Operation on an invalid type: @modal-title-padding #367

Closed
anutron opened this Issue Feb 13, 2014 · 3 comments

4 participants

@anutron
anutron commented Feb 13, 2014

In Flat-UI 1.2.5 there is a variable in variables less:

@modal-title-padding: 17px 19px 15px 24px;

that is used in modals.less thusly:

min-height: (@modal-title-padding + @modal-title-line-height);

This arithmetic breaks (at least in the compiler in Rails pipeline with the less-rails gem) because you're attempting to add that array of values with another. I double checked this with an online less (http://winless.org/online-less-compiler) compiler with this simple example:

@foo: 10px 5px 3px 1px;
@bar: 12px;

div {
  width: (@foo + @bar);
}

and got the same error.

@pytkin
pytkin commented Mar 13, 2014

Fixed

@pytkin pytkin closed this Mar 13, 2014
@pytkin pytkin added the bug label Mar 13, 2014
@benstr
benstr commented Jul 13, 2014

Are you going to release a new version of FlatUI Pro with this fix include? The latest downloadable version is 1.2.5 and that version still has the error. In the meantime please share the fix details so I can manually fix it while I wait for the update to be released.

@datapimp
datapimp commented Aug 6, 2014

@benstr +1

@pytkin please let us know when you will release an updated version of the flat ui download, and in the mean time what the fix is.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.