Permalink
Browse files

Resolving dependency issues (getting ready to release the 0.8.0 gem)

  • Loading branch information...
1 parent e55bb52 commit 13893c3b321dbb04c8bc25ec7368e39226598c2e @antonymarcano antonymarcano committed Sep 11, 2011
View
42 Examples/Calculator/Gemfile.lock
@@ -8,40 +8,41 @@ GEM
rdiscount (>= 1.6.8)
rspec (>= 2.6.0)
backports (2.3.0)
- bcat (0.6.1)
+ bcat (0.6.2)
rack (~> 1.0)
builder (3.0.0)
- capybara (1.0.0)
+ capybara (1.1.1)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
- selenium-webdriver (~> 0.2.0)
+ selenium-webdriver (~> 2.0)
xpath (~> 0.1.4)
- childprocess (0.1.9)
+ childprocess (0.2.2)
ffi (~> 1.0.6)
- cucumber (1.0.0)
+ cucumber (1.0.2)
builder (>= 2.1.2)
diff-lcs (>= 1.1.2)
- gherkin (~> 2.4.1)
+ gherkin (~> 2.4.5)
json (>= 1.4.6)
term-ansicolor (>= 1.0.5)
- cukesalad (0.7.0)
- aruba (>= 0.3.5)
- cucumber (>= 0.10.0)
+ cukesalad (0.8.0)
+ aruba (= 0.4.3)
+ cucumber (= 1.0.2)
rspec (>= 2.5.0)
- diff-lcs (1.1.2)
+ diff-lcs (1.1.3)
ffi (1.0.9)
- gherkin (2.4.1)
+ gherkin (2.4.18)
json (>= 1.4.6)
- json (1.5.3)
- json_pure (1.5.3)
+ json (1.5.4)
+ json_pure (1.5.4)
+ spruz (~> 0.2.8)
mime-types (1.16)
monkey-lib (0.5.4)
backports
nokogiri (1.5.0)
- rack (1.3.0)
- rack-test (0.6.0)
+ rack (1.3.2)
+ rack-test (0.6.1)
rack (>= 1.0)
rdiscount (1.6.8)
rspec (2.6.0)
@@ -53,14 +54,14 @@ GEM
diff-lcs (~> 1.1.2)
rspec-mocks (2.6.0)
rubyzip (0.9.4)
- selenium-webdriver (0.2.2)
- childprocess (>= 0.1.9)
+ selenium-webdriver (2.5.0)
+ childprocess (>= 0.2.1)
ffi (>= 1.0.7)
json_pure
rubyzip
sinatra (1.2.6)
rack (~> 1.1)
- tilt (< 2.0, >= 1.2.2)
+ tilt (>= 1.2.2, < 2.0)
sinatra-advanced-routes (0.5.1)
monkey-lib (~> 0.5.0)
sinatra (~> 1.0)
@@ -71,8 +72,9 @@ GEM
sinatra-sugar (0.5.1)
monkey-lib (~> 0.5.0)
sinatra (~> 1.0)
- term-ansicolor (1.0.5)
- tilt (1.3.2)
+ spruz (0.2.13)
+ term-ansicolor (1.0.6)
+ tilt (1.3.3)
xpath (0.1.4)
nokogiri (~> 1.3)
View
2 Examples/Calculator/features/lib/alternative/roles/calculating_web_user.rb
@@ -6,7 +6,7 @@
require 'capybara/dsl'
Capybara.app = WebCalculator
-Capybara.default_driver = :rack_test
+Capybara.default_driver = :selenium
module CalculatingIndividual
View
24 Gemfile.lock
@@ -1,9 +1,9 @@
PATH
remote: .
specs:
- cukesalad (0.7.0)
- aruba (>= 0.3.5)
- cucumber (>= 0.10.0)
+ cukesalad (0.8.0)
+ aruba (= 0.4.3)
+ cucumber (= 1.0.2)
rspec (>= 2.5.0)
GEM
@@ -16,28 +16,28 @@ GEM
cucumber (>= 0.10.7)
rdiscount (>= 1.6.8)
rspec (>= 2.6.0)
- bcat (0.6.1)
+ bcat (0.6.2)
rack (~> 1.0)
builder (3.0.0)
- childprocess (0.1.9)
+ childprocess (0.2.2)
ffi (~> 1.0.6)
- cucumber (1.0.0)
+ cucumber (1.0.2)
builder (>= 2.1.2)
diff-lcs (>= 1.1.2)
- gherkin (~> 2.4.1)
+ gherkin (~> 2.4.5)
json (>= 1.4.6)
term-ansicolor (>= 1.0.5)
- diff-lcs (1.1.2)
+ diff-lcs (1.1.3)
ffi (1.0.9)
ffi (1.0.9-java)
- gherkin (2.4.1)
+ gherkin (2.4.18)
json (>= 1.4.6)
- gherkin (2.4.1-java)
+ gherkin (2.4.18-java)
json (>= 1.4.6)
json (1.4.6)
json (1.4.6-java)
mime-types (1.16)
- rack (1.3.0)
+ rack (1.3.2)
rake (0.8.7)
rdiscount (1.6.8)
relish (0.3.0)
@@ -54,7 +54,7 @@ GEM
rspec-expectations (2.6.0)
diff-lcs (~> 1.1.2)
rspec-mocks (2.6.0)
- term-ansicolor (1.0.5)
+ term-ansicolor (1.0.6)
PLATFORMS
java
View
2 VERSION
@@ -1 +1 @@
-0.7.0
+0.8.0
View
4 cukesalad.gemspec
@@ -25,9 +25,9 @@ Gem::Specification.new do |s|
s.default_executable = "cukesalad"
s.require_paths = ["lib"]
- s.add_runtime_dependency "cucumber", ">=0.10.0"
+ s.add_runtime_dependency "cucumber", "1.0.2" # Version 1.0.4 experiences following error: 'Illformed requirement ["#<Syck::DefaultKey:0x000001034764a0> 0.8.4"]'
s.add_runtime_dependency "rspec", ">=2.5.0"
- s.add_runtime_dependency "aruba", ">=0.3.5"
+ s.add_runtime_dependency "aruba", "0.4.3"
s.add_development_dependency "bundler", "~> 1.0.0"
s.add_development_dependency "rake", "~> 0.8.7"
View
2 lib/cukesalad/version.rb
@@ -1,3 +1,3 @@
module CukeSalad
- VERSION = "0.7.0"
+ VERSION = "0.8.0"
end

0 comments on commit 13893c3

Please sign in to comment.