New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Pam options and fixes #111

Merged
merged 2 commits into from Apr 29, 2016

Conversation

Projects
None yet
2 participants
@foonix
Contributor

foonix commented Mar 14, 2016

This adds adds an attribute for setting pam_cracklib options and fixes #102 related problems.

  • Fixed templates not being applied if pam_passwdqc is enabled.
  • Install correct package for pam_pwquality in centos 7.
  • Add a flag to turn on/off pam_pwquality in rhel7 and set defaults appropriately based on platform_version
  • Add an attribute to set options to pam_pwquality.
  • Fall back to pam_cracklib on all patforms if neither pam_pwquality nor pam_passwdqc are enabled.
  • Don't attempt to install pam_cracklib (It comes with the pam package on rhel 5, 6, & 7)

@chris-rock Please let me know if you have any feedback about this or any of my other PRs in this repo. :)

foonix added some commits Mar 11, 2016

Fix multiple issues with PAM configuration
- Fixed templates not being applied if pam_passwdqc is enabled.
- Install correct package for pam_pwquality in centos 7.
- Add a flag to turn on/off pam_pwquality in rhel7 and set defaults appropriately based on platform_version
- Add an attribute to set options to pam_pwquality.
- Fall back to pam_cracklib on all patforms if neither pam_pwquality nor pam_passwdqc are enabled.
- Don't attempt to install pam_cracklib (It comes with the pam package on rhel 5, 6, & 7)
@foonix

This comment has been minimized.

Show comment
Hide comment
@foonix

foonix Mar 14, 2016

Contributor

Regarding pam_cracklib package, is that a fedora thing? As far as I can tell, rhel 5-7 ship with cracklib as part of 'pam'. We may want to just remove that part or condition it to where it is applicable.

Contributor

foonix commented Mar 14, 2016

Regarding pam_cracklib package, is that a fedora thing? As far as I can tell, rhel 5-7 ship with cracklib as part of 'pam'. We may want to just remove that part or condition it to where it is applicable.

@chris-rock

This comment has been minimized.

Show comment
Hide comment
@chris-rock
Member

chris-rock commented Apr 29, 2016

thanks @foonix

@chris-rock chris-rock merged commit ff9dbcd into dev-sec:master Apr 29, 2016

1 check failed

continuous-integration/travis-ci/pr The Travis CI build could not complete due to an error
Details

@foonix foonix deleted the foonix:pam-cracklib-options branch Sep 8, 2016

rollbrettler pushed a commit to rollbrettler/chef-os-hardening that referenced this pull request Sep 16, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment