Calendar breaks on iOS 5.0, works fine on 4.x #129

Closed
atlas207 opened this Issue Dec 2, 2011 · 2 comments

Comments

Projects
None yet
3 participants
@atlas207

atlas207 commented Dec 2, 2011

Hey,

It seems like every time one calendar bug gets fixed another pops up haha.

The latest commit fixed the selectDate crash, but now when I run my app on iOS 5.0 simulator and real iPhone 4, I get a weird bug where its as if the background assets don't exist. However, when I run the build on the iOS 4.3 simulator, everything shows up perfectly. Here's a screenshot of what the bug looks like.

http://s10.postimage.org/sqnmyq41l/calendarbug.png

Yikes...

@jdjennin

This comment has been minimized.

Show comment Hide comment
@jdjennin

jdjennin Jan 10, 2012

A quick and dirty solution to this is to comment out the lines in TKCalendarMonthView which utilize TKBUNDLE() to load images from tapkulibrary.bundle and instead use imageNamed: to load all the images. You must also copy the images into the project.

A quick and dirty solution to this is to comment out the lines in TKCalendarMonthView which utilize TKBUNDLE() to load images from tapkulibrary.bundle and instead use imageNamed: to load all the images. You must also copy the images into the project.

@devinross

This comment has been minimized.

Show comment Hide comment
@devinross

devinross Apr 24, 2012

Owner

You need the tk bundle included in your project.

Owner

devinross commented Apr 24, 2012

You need the tk bundle included in your project.

@devinross devinross closed this Apr 24, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment