Permalink
Browse files

added edge rails on 1.9.3 to the test matrix (with failures allowed)

  • Loading branch information...
1 parent 281b45a commit 0caca174e6a2aff11e8f5469c36f6d5ce422657d @dgeb committed Sep 21, 2012
Showing with 30 additions and 1 deletion.
  1. +21 −1 .travis.yml
  2. +9 −0 gemfiles/Gemfile.edge-rails
View
@@ -1,7 +1,27 @@
+language: ruby
rvm:
- 1.8.7
- 1.9.2
- 1.9.3
- ree
- jruby
- - rbx
+ - rbx
+gemfile:
+ - Gemfile
+ - gemfiles/Gemfile.edge-rails
+matrix:
+ exclude:
+ # Edge Rails is only compatible with 1.9.3
+ - gemfile: gemfiles/Gemfile.edge-rails
+ rvm: 1.8.7
+ - gemfile: gemfiles/Gemfile.edge-rails
+ rvm: 1.9.2
+ - gemfile: gemfiles/Gemfile.edge-rails
+ rvm: ree
+ - gemfile: gemfiles/Gemfile.edge-rails
+ rvm: jruby
+ - gemfile: gemfiles/Gemfile.edge-rails
+ rvm: rbx
+ allow_failures:
+ - gemfile: gemfiles/Gemfile.edge-rails
+ rvm: 1.9.3
@@ -0,0 +1,9 @@
+source 'http://rubygems.org'
+
+gemspec :path => '..'
+
+gem 'rails', github: 'rails/rails'
+
+# Current dependencies of edge rails
+gem 'journey', github: 'rails/journey'
+gem 'activerecord-deprecated_finders' , github: 'rails/activerecord-deprecated_finders'

0 comments on commit 0caca17

Please sign in to comment.