Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

add thin as web server

  • Loading branch information...
commit 6b9f0fb68e4bd9d39e4afdc9d1f88efa9a311618 1 parent c3e7cef
@dgilperez authored
Showing with 26 additions and 13 deletions.
  1. +16 −13 Gemfile
  2. +10 −0 Gemfile.lock
View
29 Gemfile
@@ -2,6 +2,8 @@ require 'rbconfig'
HOST_OS = RbConfig::CONFIG['host_os']
source 'https://rubygems.org'
+gem 'thin'
+
gem 'rails', '3.2.3'
group :assets do
@@ -32,6 +34,20 @@ group :development, :test do
gem "guard-rails", ">= 0.0.3"
gem "guard-livereload", ">= 0.3.0"
gem "guard-rspec", ">= 0.4.3"
+
+ case HOST_OS
+ when /darwin/i
+ gem 'rb-fsevent'
+ gem 'growl'
+ when /linux/i
+ gem 'libnotify'
+ gem 'rb-inotify'
+ when /mswin|windows/i
+ gem 'rb-fchange'
+ gem 'win32console'
+ gem 'rb-notifu'
+ end
+
end
group :test do
@@ -40,19 +56,6 @@ group :test do
gem "email_spec", ">= 1.2.1"
end
-# case HOST_OS
-# when /darwin/i
-# gem 'rb-fsevent'
-# gem 'growl'
-# when /linux/i
-# gem 'libnotify'
-# gem 'rb-inotify'
-# when /mswin|windows/i
-# gem 'rb-fchange'
-# gem 'win32console'
-# gem 'rb-notifu'
-# end
-
gem "bson_ext", ">= 1.6.2"
gem "mongoid", ">= 2.4.8"
View
10 Gemfile.lock
@@ -44,6 +44,7 @@ GEM
coffee-script-source
execjs
coffee-script-source (1.3.1)
+ daemons (1.1.8)
database_cleaner (0.7.2)
diff-lcs (1.1.3)
em-websocket (0.3.6)
@@ -65,6 +66,7 @@ GEM
font-awesome-sass-rails (0.2.0)
railties (>= 3.1.1)
sass-rails (>= 3.1.1)
+ growl (1.0.3)
guard (1.0.1)
ffi (>= 0.5.0)
thor (~> 0.14.6)
@@ -143,6 +145,7 @@ GEM
rdoc (~> 3.4)
thor (~> 0.14.6)
rake (0.9.2.2)
+ rb-fsevent (0.9.1)
rdoc (3.12)
json (~> 1.4)
rspec (2.9.0)
@@ -170,6 +173,10 @@ GEM
hike (~> 1.2)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
+ thin (1.3.1)
+ daemons (>= 1.0.9)
+ eventmachine (>= 0.12.6)
+ rack (>= 1.0.0)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
@@ -192,6 +199,7 @@ DEPENDENCIES
email_spec (>= 1.2.1)
factory_girl_rails (>= 3.1.0)
font-awesome-sass-rails
+ growl
guard (>= 0.6.2)
guard-bundler (>= 0.1.3)
guard-livereload (>= 0.3.0)
@@ -206,7 +214,9 @@ DEPENDENCIES
omniauth-twitter
rails (= 3.2.3)
rails-footnotes (>= 3.7)
+ rb-fsevent
rspec-rails (>= 2.9.0.rc2)
sass-rails (~> 3.2.3)
simple_form
+ thin
uglifier (>= 1.0.3)
Please sign in to comment.
Something went wrong with that request. Please try again.