Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Updating dependencies version numbers #13

Merged
merged 1 commit into from

2 participants

@swaroopch

Because of old clj-time version, it was causing conflicts in the project that I was working on, which already had a dependency on [clj-time 0.6.0] and hence lein repl would die with:

Caused by: java.lang.ClassNotFoundException: clj_time.core.DateTimeProtocol
        at java.net.URLClassLoader$1.run(URLClassLoader.java:372)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:360)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
        ... 183 more
Subprocess failed

If I update the clj-time dependency version, then it seems to work fine.

@dgrnbrg dgrnbrg merged commit 0c73d33 into dgrnbrg:master
@dgrnbrg
Owner

Thank you for this!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jun 3, 2014
  1. @swaroopch
This page is out of date. Refresh to see the latest.
Showing with 2 additions and 2 deletions.
  1. +2 −2 project.clj
View
4 project.clj
@@ -3,5 +3,5 @@
:url "http://github.com/dgrnbrg/spyscope"
:license {:name "Eclipse Public License"
:url "http://www.eclipse.org/legal/epl-v10.html"}
- :dependencies [[org.clojure/clojure "1.4.0"]
- [clj-time "0.5.0"]])
+ :dependencies [[org.clojure/clojure "1.6.0"]
+ [clj-time "0.7.0"]])
Something went wrong with that request. Please try again.