Permalink
Browse files

- Fix for bug in syck causing install to fail when gem packaged w/ psych

  • Loading branch information...
1 parent d599bac commit 4726990073bbce3384032880d789c08eada4b8ad @zenspider zenspider committed Feb 23, 2011
Showing with 2 additions and 1 deletion.
  1. +2 −1 lib/rubygems/requirement.rb
View
3 lib/rubygems/requirement.rb
@@ -131,7 +131,8 @@ def pretty_print q # :nodoc:
# True if +version+ satisfies this Requirement.
def satisfied_by? version
- requirements.all? { |op, rv| OPS[op].call version, rv }
+ # #28965: syck has a bug with unquoted '=' YAML.loading as YAML::DefaultKey
+ requirements.all? { |op, rv| (OPS[op] || OPS["="]).call version, rv }
end
def to_s # :nodoc:

0 comments on commit 4726990

Please sign in to comment.