rake tolk:setup fails #11

Closed
rolfb opened this Issue Jun 7, 2010 · 7 comments

Comments

Projects
None yet
6 participants
@rolfb

rolfb commented Jun 7, 2010

this happens when i try to run rake:setup

DEPRECATION WARNING: railtie_name is deprecated and has no effect. (called from /Users/rolf/.rvm/gems/ruby-1.8.7-p174/gems/tolk-1.0/lib/tolk/engine.rb:5) [WARNING] Could not load generator "generators/tolk_migration/tolk_migration_generator". Error: wrong number of arguments (1 for 0). /Users/rolf/.rvm/gems/ruby-1.8.7-p174/gems/tolk-1.0/lib/generators/tolk_migration/tolk_migration_generator.rb:4:in `source_root' /Users/rolf/.rvm/gems/ruby-1.8.7-p174/gems/tolk-1.0/lib/generators/tolk_migration/tolk_migration_generator.rb:4

tried both gem and source (rails3 branch)

@ghost

This comment has been minimized.

Show comment Hide comment
@ghost

ghost Jun 21, 2010

I've got the same problem here...

ghost commented Jun 21, 2010

I've got the same problem here...

@fedegl

This comment has been minimized.

Show comment Hide comment
@fedegl

fedegl Mar 7, 2011

Same problem

fedegl commented Mar 7, 2011

Same problem

@borisrorsvort

This comment has been minimized.

Show comment Hide comment
@borisrorsvort

borisrorsvort Apr 13, 2011

i have exactly the same, then he says:

uninitialized constant Tolk::Sync

i have exactly the same, then he says:

uninitialized constant Tolk::Sync

@matthiasjakel

This comment has been minimized.

Show comment Hide comment
@matthiasjakel

matthiasjakel Apr 14, 2011

@borisrorsvort you have to add the following lines to your app @ YOUR_APP/config/application.rb

require 'tolk'
require 'tolk/sync'
require 'tolk/import'

then it will work!

@borisrorsvort you have to add the following lines to your app @ YOUR_APP/config/application.rb

require 'tolk'
require 'tolk/sync'
require 'tolk/import'

then it will work!

@borisrorsvort

This comment has been minimized.

Show comment Hide comment
@borisrorsvort

borisrorsvort Apr 14, 2011

I figured out in the meanwhile, but thanks! :)

I figured out in the meanwhile, but thanks! :)

@ghost

This comment has been minimized.

Show comment Hide comment
@ghost

ghost Apr 15, 2011

Thanks @matthiasjakel that works to me! But after require 'rails/all'

ghost commented Apr 15, 2011

Thanks @matthiasjakel that works to me! But after require 'rails/all'

@thomasdarde

This comment has been minimized.

Show comment Hide comment
@thomasdarde

thomasdarde May 15, 2012

Collaborator

This has been fixed in 1.1.0 (now available at github.com/tolk/tolk)

Collaborator

thomasdarde commented May 15, 2012

This has been fixed in 1.1.0 (now available at github.com/tolk/tolk)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment