Skip to content

Rails 3.1 support #33

Closed
wants to merge 36 commits into from

8 participants

@miloops
miloops commented Nov 14, 2011

This branch is working with Rails 3.1.1. Most of the work is by @drogus. I modified it to work with latest will_paginate and removed warnings.

lifo and others added some commits Jun 3, 2010
@lifo lifo Make migration generator work with Rails 3 c69d728
@lifo lifo named_scope -> scope and <% -> <%= ff92009
@lifo lifo Latest will_paginate/rails3 6f3bedf
@lifo lifo Remove bundled will_paginate 162d791
@lifo lifo No need for monkey patched link renderer de6ca66
@lifo lifo Add Gemfile for will_paginate/rails3 a226141
@lifo lifo More rails3 compatibility and get rid of custom LinkRenderer 17625d6
@lifo lifo Move tasks to lib/ 83ffa4b
@lifo lifo Add a gemspec a496269
@lifo lifo Engine definition for Rails 3 9d2883f
@lifo lifo Fix gemspec cc96ff9
@lifo lifo Use Rails 3 route syntax 274c5c6
@lifo lifo Require w_p and ya2yaml 66a0a57
@lifo lifo Add rake tolk:import_assets for copying asstes to the app 0cf67e0
@dhh The lines must line up 29576df
@dhh Rails 3 wants Mime::YAML not YML 18fb33c
@dhh Add a setup task that does all the legwork of getting Tolk running in…
… your app
77d0ed3
@dhh Update readme for Rails 3 and setup stuff 4a13f0b
@dhh Add a changelog 22f34f5
@wvanbergen wvanbergen Added simple variable checking when validating translations. ac77341
@wvanbergen wvanbergen Also detect %{variable} in translations. 7d7ed74
@lifo lifo Merge remote branch 'wvanbergen/master' into rails3 863399b
@drogus drogus Converted tolk to mountable engine
2 tests still fail and integration tests must be run with selenium
because of bug in capybara.
7e06bea
@drogus drogus Ignore logs and db files in test/dummy 7834c75
@drogus drogus Seems like in older versions of AR fixnums were converted to strings …
…in serialized column
b5f955e
@drogus drogus Serialize previous_text to avoid errors on save 9d9eb96
@drogus drogus Removed has_rdoc from gemspec a57c549
@drogus drogus namespace -> isolate_namespace 925e720
@drogus drogus Do not require specific version of will paginate 96e3ddc
@drogus drogus Fixed tolk to work on 3.1 b51ad4d
@drogus drogus We don't need to copy assets anymore 6b52dc1
@drogus drogus Move everything to one migration b4456e2
@drogus drogus Remove test dummy logs 06956fd
@miloops miloops Working on Rails 3.1.1, removed warnings, added will_paginate support…
… again.
70f755e
@miloops miloops We don't import assets anymore. e6bc668
@SUzB
SUzB commented Jan 6, 2012

What is the benefit of tolk. Isn't it covered with 3.1.1? http://guides.rubyonrails.org/i18n.html

@drogus
drogus commented Jan 6, 2012

@SUzB tolk gives you nice frontend for managing your translations. it's good if you have non-technical translators.

@thomasdarde
Collaborator

This has been merged in tolk 1.1.0.
Thanks

@w-A-L-L-e

Thanks! Love tolk and great it works in new rails version now!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.