Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Correctly enable the asset pipeline

* Add the Rails 3.1+ Bundler.require statement to config/application.rb
  (properly enabling the :assets group)
* Move handlebars_assets gem into the :assets group where it belongs. :)
* Downgrade sass-rails to 3.1.4 since enabling the :assets group exposed
  a known bug in sass-rails ~> 3.1.5 [rails/sass-rails#78].
  • Loading branch information...
commit b24a4a72132c3470b846a4351602bdca0d3836ef 1 parent 3e4bdc4
@stevenh512 stevenh512 authored maxwell committed
Showing with 13 additions and 8 deletions.
  1. +2 −2 Gemfile
  2. +4 −3 Gemfile.lock
  3. +7 −3 config/application.rb
View
4 Gemfile
@@ -108,10 +108,10 @@ gem 'client_side_validations'
# assets
group :assets do
- gem 'sass-rails'
+ gem 'sass-rails', '3.1.4'
+ gem 'handlebars_assets'
gem 'uglifier'
end
-gem 'handlebars_assets'
gem 'jquery-rails'
View
7 Gemfile.lock
@@ -413,10 +413,11 @@ GEM
archive-tar-minitar (>= 0.5.2)
rubyzip (0.9.6.1)
sass (3.1.15)
- sass-rails (3.1.6)
+ sass-rails (3.1.4)
actionpack (~> 3.1.0)
railties (~> 3.1.0)
- sass (>= 3.1.10)
+ sass (>= 3.1.4)
+ sprockets (~> 2.0.0)
tilt (~> 1.3.2)
selenium-webdriver (2.16.0)
childprocess (>= 0.2.5)
@@ -558,7 +559,7 @@ DEPENDENCIES
ruby-debug19
ruby-oembed (~> 0.8.7)
sass
- sass-rails
+ sass-rails (= 3.1.4)
selenium-webdriver (~> 2.16.0)
settingslogic!
sqlite3
View
10 config/application.rb
@@ -13,9 +13,13 @@
end
require 'rails/all'
-# If you have a Gemfile, require the gems listed there, including any gems
-# you've limited to :test, :development, or :production.
-Bundler.require(:default, Rails.env) if defined?(Bundler)
+
+if defined?(Bundler)
+ # If you precompile assets before deploying to production, use this line
+ Bundler.require(*Rails.groups(:assets => %w(development test)))
+ # If you want your assets lazily compiled in production, use this line
+ # Bundler.require(:default, :assets, Rails.env)
+end
module Diaspora
Please sign in to comment.
Something went wrong with that request. Please try again.