Permalink
Browse files

Basic 1.9.2 port

  • Loading branch information...
1 parent 7334501 commit c6f5b4ed161e5b6feb9acdc907dc287fc807f0cb @manveru manveru committed Sep 16, 2010
View
1 Gemfile
@@ -54,7 +54,6 @@ end
group :development do
gem 'nifty-generators'
- gem 'ruby-debug'
end
group :deployment do
View
2 app/models/profile.rb
@@ -5,7 +5,7 @@
class Profile
include MongoMapper::EmbeddedDocument
- require 'lib/diaspora/webhooks'
+ require_relative '../../lib/diaspora/webhooks'
include Diaspora::Webhooks
include ROXML
View
10 app/models/user.rb
@@ -3,9 +3,9 @@
# the COPYRIGHT file.
-require 'lib/diaspora/user/friending.rb'
-require 'lib/diaspora/user/querying.rb'
-require 'lib/salmon/salmon'
+require_relative '../../lib/diaspora/user/friending.rb'
+require_relative '../../lib/diaspora/user/querying.rb'
+require_relative '../../lib/salmon/salmon'
class User
include MongoMapper::Document
@@ -295,11 +295,11 @@ def seed_aspects
aspect(:name => "Family")
aspect(:name => "Work")
end
-
+
def self.create(opts ={})
puts opts.inspect
end
-
+
def terse_url
terse = self.url.gsub(/(https?:|www\.)\/\//, '')
terse = terse.chop! if terse[-1, 1] == '/'
View
2 config/application.rb
@@ -13,7 +13,7 @@
# you've limited to :test, :development, or :production.
Bundler.require(:default, Rails.env) if defined?(Bundler)
-require 'lib/mongo_mapper/bson_id'
+require_relative '../lib/mongo_mapper/bson_id'
module Diaspora
class Application < Rails::Application
# Settings in config/environments/* take precedence over those specified here.
View
2 config/environment.rb
@@ -5,7 +5,7 @@
# Load the rails application
-require File.expand_path('../application', __FILE__)
+require_relative 'application'
Haml::Template.options[:format] = :html5
# Initialize the rails application
Diaspora::Application.initialize!
View
2 config/environments/development.rb
@@ -3,7 +3,7 @@
# the COPYRIGHT file.
-require 'lib/mongo_mapper/clear_dev_memory'
+require_relative '../../lib/mongo_mapper/clear_dev_memory'
Diaspora::Application.configure do
# Settings specified here will take precedence over those in config/environment.rb
View
2 config/initializers/socket.rb
@@ -5,7 +5,7 @@
require 'em-websocket'
require 'eventmachine'
-require "lib/diaspora/websocket"
+require_relative "../../lib/diaspora/websocket"
EM.next_tick {
Diaspora::WebSocket.initialize_channels
View
2 script/rails
@@ -1,4 +1,4 @@
-#!/usr/bin/env ruby1.8
+#!/usr/bin/env ruby
# This command will automatically be run when you run "rails" with Rails 3 gems installed from the root of your application.
APP_PATH = File.expand_path('../../config/application', __FILE__)

0 comments on commit c6f5b4e

Please sign in to comment.