Firefox: Text in publisher disappears when uploading an image #2770

Closed
gandaro opened this Issue Jan 29, 2012 · 6 comments

Projects

None yet

4 participants

@gandaro
gandaro commented Jan 29, 2012

When writing a post with an image, the text disappears after uploading an image. An example (there actually is text in the textbox):

Bug

Edit: I have just got Diaspora running on my machine again, and it works here but not on Geraspora.
Edit no. 2: Turns out, my Diaspora instance was outdated and after updating it doesn't work.

@gandaro gandaro closed this Jan 29, 2012
@gandaro gandaro reopened this Jan 29, 2012
@sarahmei
Member

What browser/OS are you on?

@sarahmei
Member

This happens for me on FF9/OSX. It does not happen on Chrome/OSX

@gandaro
gandaro commented Jan 29, 2012

What browser/OS are you on?

Ubuntu 11.10 with Firefox 9.0.1. Works for me with Chromium/Ubuntu too.

@kas70
kas70 commented Jan 30, 2012

i can't set the cursor in the publisher after uploading a picture, too. so i can't type something after uploading a picture.

i'm on firefox 9.0.1/windows 7

@Raven24
Member
Raven24 commented Feb 19, 2012

This is still an issue with FF10/Linux.
... looking into it

@Raven24 Raven24 added a commit to Raven24/diaspora that referenced this issue Feb 19, 2012
@Raven24 Raven24 fix for #2770
 - apply the padding to the wrapper element, not to the textarea
   apparently padding a textarea makes it shrink in firefox... ?
 - don't use manual padding, instead specify max-height for images
   extra-huge images are jolted, but they don't explode the layout
 - closing handled by view,
   gets rid of "Publisher.close is not a function" error msg
7c73a52
@Raven24
Member
Raven24 commented Mar 7, 2012

pull request merged, should be fixed now (don't forget to clear the browser cache)

@gandaro gandaro closed this Mar 7, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment