Fails to open stream (new install) #2819

Closed
liamn11 opened this Issue Feb 4, 2012 · 1 comment

Comments

Projects
None yet
2 participants

liamn11 commented Feb 4, 2012

When trying to open the stream on a new install I receive an error page:-
Settingslogic::MissingSetting in Streams#multi

Showing /Users/*******/diaspora/app/views/shared/_invitations.haml where line #1 raised:

Missing setting 'configured_services' in /Users/*******/diaspora/config/application.yml
Extracted source (around line #1):

1: - if AppConfig.configured_services.include?('facebook')
2: - if defined? remote
3: = link_to t('.from_facebook'), friend_finder_path('facebook', :remote => remote)
4: -else
Trace of template inclusion: app/views/shared/_right_sections.html.haml, app/views/layouts/main_stream.html.haml

Rails.root: /Users/*******/diaspora

Application Trace | Framework Trace | Full Trace
app/views/shared/_invitations.haml:1:in _app_views_shared__invitations_haml__285587960_2235502260_1629950' app/views/shared/_right_sections.html.haml:13:in_app_views_shared__right_sections_html_haml___291950037_2234256060_5767870'
app/views/layouts/main_stream.html.haml:72:in _app_views_layouts_main_stream_html_haml___873214360_2241493380_0' app/controllers/streams_controller.rb:66:instream_responder'
app/controllers/streams_controller.rb:65:in stream_responder' app/controllers/streams_controller.rb:39:inmulti'
lib/rack/chrome_frame.rb:39:in `call'

liamn11 closed this Feb 4, 2012

Owner

sarahmei commented Feb 4, 2012

When this happens, you need to restart the server.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment