Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

publisher mentions ui glitch #4813

Closed
Raven24 opened this Issue · 12 comments

6 participants

@Raven24
Owner

I suppose our recent update to jQuery 1.10 (#4681) broke the mentions plugin (hopefully just visually).
d_mentions_glitch

this opens up a bigger discussion, since the plugin is now unmaintained and it would need some adaptions. see also: Loomio discussion about taking over maintainership

@Flaburgan

Just to be clear, because I didn't understand that it was that, it's not only text that you're going to mention, it's every text you are entering in the publisher that is directly duplicate at the bottom of the publisher in the #mention div. I would not have pulled that into diaspora-fr if I had understood that...

@jhass jhass added this to the next milestone
@Flaburgan Flaburgan referenced this issue
Merged

Port publisher and bookmarklet to bootstrap #4678

4 of 4 tasks complete
@Flaburgan

@Raven24 any chance to see a quick fix of that before integrating a whole new plugin?

@jaywink
Collaborator

selection_046

Very funky indeed :)

@jaywink jaywink added the confirmed label
@fabianrbz
Collaborator

ok, as mentioned in loomio, there is a fork whit a commit that fixes the issue...
but if we don't want to to that I think that changing this into a span will do the trick without changing upstream code....

we need to test it in different browsers, it could work while we decide what to do with the plugin...

@Flaburgan

Wow, nice catch @fabianrbz, it works! I'm gonna open a PR right now, we need to fix develop asap.

@jaywink jaywink closed this in #4845
@jaywink
Collaborator

Oh github closed this automatically from @Flaburgan's commit. @Raven24 want to open a new issue to track the upstream plugin replacement work?

@svbergerem
Collaborator

Has this been fixed for the new publisher?

@Flaburgan

No sorry

@jaywink
Collaborator

Reopening for the bookmarklet publisher - verified still an issue there.

@jaywink jaywink reopened this
@fabianrbz
Collaborator

what the problem with this issue? hasn't it been fixed in @Flaburgan's PR?

@jaywink
Collaborator
@fabianrbz
Collaborator

ok, that's probably because it's using a different partial, but the solution used in @Flaburgan's PR is also valid for the new publisher -just changing the div for a span-. I'm not sure why we have two partials :/

@jhass jhass closed this in #4890
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.