Skip to content
Find file
Fetching contributors…
Cannot retrieve contributors at this time
33 lines (19 sloc) 1.11 KB

da-js – Collection of small, useful JavaScripts

This are some JavaScripts we use in most of our projects. So packaged them into a gem.

Okay, right now it’s only one, small JavaScript. But just be patient …


da-js is meant to be used with Ruby on Rails 3.1 or newer. It's based on jQuery, so be sure you are using jquery-rails, too (jQuery version 1.7.1 or newer is required).

To install it:

  • Add the gem to your Gemfile:

    gem "da-js"
  • Require the library in your application.js (after requiring jQuery):

    require "da-js"


For documentation please refer to the individual files in lib/assets/javascripts/da-js.


Use the Rack application in features/support/testapp:

rackup features/support/testapp/

Any template file in features/support/testapp/views can be accessed by its basename:

open http:://localhost:9292/form_change_tracker

Run the tests with

rake test
Jump to Line
Something went wrong with that request. Please try again.