Skip to content
Browse files

[scanner] Make it compatible with Python 2.5 again

with statement is available in python 2.5, but only
if you import it from __future__
  • Loading branch information...
1 parent 073fba5 commit 2eb614e805311841e17fd4dbe76aa70443f3a911 Johan Dahlin committed
Showing with 3 additions and 0 deletions.
  1. +3 −0 giscanner/codegen.py
View
3 giscanner/codegen.py
@@ -18,7 +18,10 @@
# Boston, MA 02111-1307, USA.
#
+from __future__ import with_statement
+
from contextlib import contextmanager
+
from . import ast
class CCodeGenerator(object):

0 comments on commit 2eb614e

Please sign in to comment.
Something went wrong with that request. Please try again.