Skip to content
Permalink
Browse files

Merge branch '8.x' of github.com:drupal-composer/drupal-project into …

…8.x-upstream

* '8.x' of github.com:drupal-composer/drupal-project:
  Update composer.json to require latest stable version of Drupal (drupal-composer#424)
  Bump minimum required composer-patches version to support default patch level (drupal-composer#410)
  Adjust default core patch level to -p2. (drupal-composer#418)

# Conflicts:
#	composer.json
  • Loading branch information...
daften committed Sep 10, 2018
2 parents 8f6ade3 + c1e2b6e commit fe66820e9ea493552c66bc3ee5f2914b9ab824c5
Showing with 10 additions and 13 deletions.
  1. +1 −1 .travis.yml
  2. +9 −12 composer.json
@@ -35,7 +35,7 @@ install:

script:
- if [[ $RELEASE = dev ]]; then composer --verbose remove --no-update drupal/console; fi;
- if [[ $RELEASE = dev ]]; then composer --verbose require --no-update drupal/core:8.6.x-dev webflo/drupal-core-require-dev:8.6.x-dev; fi;
- if [[ $RELEASE = dev ]]; then composer --verbose require --no-update drupal/core:8.7.x-dev webflo/drupal-core-require-dev:8.7.x-dev; fi;
- if [[ $RELEASE = dev ]]; then composer --verbose update; fi;
- cd $TRAVIS_BUILD_DIR/web
- ./../vendor/bin/drush site-install --verbose --yes --db-url=sqlite://tmp/site.sqlite
@@ -29,31 +29,27 @@
],
"require": {
"composer/installers": "^1.2",
"cweagans/composer-patches": "^1.6",
"cweagans/composer-patches": "^1.6.5",
"digipolisgent/robo-digipolis-drupal8": "^0.1",
"drupal-composer/drupal-scaffold": "^2.5",
"drupal/console": "^1.0.2",
"drupal/core": "~8.5.3",
"drupal/core": "^8.6.0",
"drush/drush": "^9.0.0",
"vlucas/phpdotenv": "^2.4",
"webflo/drupal-finder": "^1.0.0",
"gent-drupal/digipolis": "~8.1",
"oomphinc/composer-installers-extender": "^1.1",
"webmozart/path-util": "^2.3"
},
"require-dev": {
"webflo/drupal-core-require-dev": "~8.5.3"
"webflo/drupal-core-require-dev": "^8.6.0"
},
"conflict": {
"drupal/drupal": "*"
},
"minimum-stability": "dev",
"prefer-stable": true,
"config": {
"sort-packages": true,
"platform": {
"php": "5.6.20"
}
"sort-packages": true
},
"autoload": {
"classmap": [
@@ -69,15 +65,16 @@
"DrupalProject\\composer\\ScriptHandler::checkComposerVersion"
],
"post-install-cmd": [
"DrupalProject\\composer\\ScriptHandler::createRequiredFiles",
"@composer drupal-scaffold"
"DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
],
"post-update-cmd": [
"DrupalProject\\composer\\ScriptHandler::createRequiredFiles",
"@composer drupal-scaffold"
"DrupalProject\\composer\\ScriptHandler::createRequiredFiles"
]
},
"extra": {
"patchLevel": {
"drupal/core": "-p2"
},
"installer-types": [
"bower-asset",
"npm-asset"

0 comments on commit fe66820

Please sign in to comment.
You can’t perform that action at this time.