Baton::API is meant to be subclassed but uses static config #14

Open
goblin opened this Issue Feb 5, 2013 · 0 comments

Comments

Projects
None yet
1 participant
Contributor

goblin commented Feb 5, 2013

If an application wants to use multiple Baton APIs which use different exchanges, the Baton::API.publish method can't be used because it uses Baton.configuration and that can only be set up once for an entire application.

It's currently not possible to have configs for more than one Baton API within the same application.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment