This repository has been archived by the owner. It is now read-only.
Permalink
Browse files

Adding jQuery plugin manifest

  • Loading branch information...
digitalBush committed Jan 17, 2013
1 parent 944165b commit 2c5075f3f61268997d8ca4d24cef7977fc5554a1
Showing with 25 additions and 2 deletions.
  1. +1 −1 LICENSE
  2. +1 −1 README.md
  3. +23 −0 maskedinput.jquery.json
View
@@ -1,4 +1,4 @@
-Copyright (c) 2007-2010 Josh Bush (digitalbush.com)
+Copyright (c) 2007-2013 Josh Bush (digitalbush.com)
Permission is hereby granted, free of charge, to any person
obtaining a copy of this software and associated documentation
View
@@ -3,7 +3,7 @@ Masked Input Plugin for jQuery
Overview
--------
-This is a masked input plugin for the jQuery javascript library. It allows a user to more easily enter fixed width input where you would like them to enter the data in a certain format (dates,phone numbers, etc). It has been tested on Internet Explorer 6/7, Firefox 1.5/2/3, Safari, Opera, and Chrome. A mask is defined by a format made up of mask literals and mask definitions. Any character not in the definitions list below is considered a mask literal. Mask literals will be automatically entered for the user as they type and will not be able to be removed by the user.The following mask definitions are predefined:
+This is a masked input plugin for the jQuery javascript library. It allows a user to more easily enter fixed width input where you would like them to enter the data in a certain format (dates,phone numbers, etc). It has been tested on Internet Explorer, Firefox, Safari, Opera, and Chrome. A mask is defined by a format made up of mask literals and mask definitions. Any character not in the definitions list below is considered a mask literal. Mask literals will be automatically entered for the user as they type and will not be able to be removed by the user.The following mask definitions are predefined:
* a - Represents an alpha character (A-Z,a-z)
* 9 - Represents a numeric character (0-9)
View
@@ -0,0 +1,23 @@
+{
+ "name": "maskedinput",
+ "title": "jQuery Masked Input",
+ "description": "jQuery plugin for forcing fixed width inputs to follow a certain patern.",
+ "keywords": ["input", "form", "mask"],
+ "version": "1.3",
+ "author": {
+ "name": "Josh Bush",
+ "url": "http://digitalbush.com"
+ },
+ "licenses": [
+ {
+ "type": "MIT",
+ "url": "https://raw.github.com/digitalBush/jquery.maskedinput/master/LICENSE"
+ }
+ ],
+ "bugs": "https://github.com/digitalBush/jquery.maskedinput/issues",
+ "homepage": "http://digitalbush.com/projects/masked-input-plugin/",
+ "docs": "http://digitalbush.com/projects/masked-input-plugin/#usage",
+ "dependencies": {
+ "jquery": ">=1.5"
+ }
+}

3 comments on commit 2c5075f

@gnarf

This comment has been minimized.

Show comment
Hide comment
@gnarf

gnarf Jan 17, 2013

You're going to need to retag your version # - It should be 1.3.0 not 1.3 -- make sure to tag it with this .json file there though!

You're going to need to retag your version # - It should be 1.3.0 not 1.3 -- make sure to tag it with this .json file there though!

@digitalBush

This comment has been minimized.

Show comment
Hide comment
@digitalBush

digitalBush Jan 17, 2013

Owner

thanks! I was wondering what was going on. :)

Owner

digitalBush replied Jan 17, 2013

thanks! I was wondering what was going on. :)

@barbagallo

This comment has been minimized.

Show comment
Hide comment
@barbagallo

barbagallo Jan 27, 2014

You should check for the lowest common denominator w/ respect to the jQuery support. e.g. JQ 1.7.1 works just fine with v1.3.1...there's no need to restrict the compatibility.

You should check for the lowest common denominator w/ respect to the jQuery support. e.g. JQ 1.7.1 works just fine with v1.3.1...there's no need to restrict the compatibility.

Please sign in to comment.