Permalink
Browse files

Add travis-ci support.

- Thanks to @bollwyvl for the patch.
- Bumped Python requirement to 2.6 to avoid compatibility cruft.
  • Loading branch information...
1 parent 0a8a590 commit 809a451f836f93379de055997e76fd80c834d23c @davidlehn davidlehn committed Aug 6, 2013
Showing with 21 additions and 1 deletion.
  1. +4 −0 .gitignore
  2. +13 −0 .travis.yml
  3. +4 −1 README.rst
View
@@ -2,7 +2,11 @@
*.sw[op]
*~
.coverage
+.project
+.pydevproject
+.settings
MANIFEST
+build
cover
dist
docs/_build
View
@@ -0,0 +1,13 @@
+language: python
+python:
+ - "2.6"
+ - "2.7"
+ - "3.2"
+ - "3.3"
+# no requirements, but simulate what a user would see
+install: pip install .
+# download test suite and run tests... submodule? meta testing project with
+# all of the reference implementations?
+script:
+ - git clone https://github.com/json-ld/json-ld.org.git spec
+ - python tests/runtests.py -d spec/test-suite/tests
View
@@ -1,6 +1,9 @@
PyLD
====
+.. image:: https://travis-ci.org/digitalbazaar/pyld.png
+ :target: https://travis-ci.org/digitalbazaar/pyld
+
Introduction
------------
@@ -41,7 +44,7 @@ Commercial support for this library is available upon request from
Requirements
------------
-- Python_ (2.5 or later)
+- Python_ (2.6 or later)
Source
------

0 comments on commit 809a451

Please sign in to comment.