New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

MaxTo 2.0.0-alpha5 // Process not starting properly #236

Closed
derek-shnosh opened this Issue Jul 10, 2018 · 10 comments

Comments

Projects
None yet
3 participants
@derek-shnosh

derek-shnosh commented Jul 10, 2018

Windows 10, build 1803 64-bit

Whenever I launch MaxTo 2.0.0-alpha5, two processes spawn but nothing shows up in systray and program doesn't function.

image

If I close the second process (the process without the --waitforexit flag), the three new processes are spawned and the icon shows up in the systray and I can configure/use the program functions.

image

@vegardlarsen vegardlarsen self-assigned this Jul 16, 2018

@vegardlarsen vegardlarsen added the bug label Jul 16, 2018

@vegardlarsen vegardlarsen added this to the 2.0.0-beta.1 milestone Jul 16, 2018

@vegardlarsen

This comment has been minimized.

Member

vegardlarsen commented Jul 16, 2018

This is very strange. I will try to investigate what happens here, but I am currently on paternity leave, and I will not have a chance to look at this until I am back (8 weeks remaining).

@derek-shnosh

This comment has been minimized.

derek-shnosh commented Jul 17, 2018

Congratulations! Enjoy your time!

@davidermined

This comment has been minimized.

davidermined commented Jul 17, 2018

Sounds great. See you in two months!

@vegardlarsen

This comment has been minimized.

Member

vegardlarsen commented Oct 3, 2018

Do you get a UAC elevation prompt when this happens? Do you have elevation enabled in MaxTo?

@derek-shnosh

This comment has been minimized.

derek-shnosh commented Oct 4, 2018

@vegardlarsen, Yes, and yes. I do get a UAC prompt and elevation is enabled.

Edit: Yes and no; I get a UAC prompt, but I'm quite sure that I did enable elevation initially but then disabled it.

Here is a screenshot of my settings;
image

Also, welcome back, hope all is well with the new addition.

@vegardlarsen

This comment has been minimized.

Member

vegardlarsen commented Oct 5, 2018

Everything is well :)

Could you check your settings file (%AppData%\MaxTo\config.json) and post it here?

@derek-shnosh

This comment has been minimized.

derek-shnosh commented Oct 5, 2018

Sure thing, here you go.

{
  "$schema": "https://maxto.net/config.schema.json",
  "startup": {
    "startWithWindows": true,
    "runElevated": true
  },
  "updates": {
    "enabled": true,
    "channel": "Alpha"
  },
  "snap": {
    "to": [
      "Screen",
      "Window"
    ],
    "distance": 10
  },
  "shims": {
    "toggled": {}
  },
  "license": {
    "firstStart": "2018-06-22T22:04:49.0901381Z"
  },
  "recipes": [
    {
      "name": "Move window left",
      "hotkey": "Windows+NumPad4",
      "ingredients": [
        {
          "command": "window:move",
          "parameters": {
            "direction": "Left"
          }
        }
      ]
    },
    {
      "name": "Move window up",
      "hotkey": "Windows+NumPad8",
      "ingredients": [
        {
          "command": "window:move",
          "parameters": {
            "direction": "Up"
          }
        }
      ]
    },
    {
      "name": "Move window right",
      "hotkey": "Windows+NumPad6",
      "ingredients": [
        {
          "command": "window:move",
          "parameters": {
            "direction": "Right"
          }
        }
      ]
    },
    {
      "name": "Move window down",
      "hotkey": "Windows+NumPad2",
      "ingredients": [
        {
          "command": "window:move",
          "parameters": {
            "direction": "Down"
          }
        }
      ]
    },
    {
      "name": "Swap window left",
      "hotkey": "Windows+Control+NumPad4",
      "ingredients": [
        {
          "command": "window:move",
          "parameters": {
            "direction": "Left",
            "swap": true
          }
        }
      ]
    },
    {
      "name": "Swap window up",
      "hotkey": "Windows+Control+NumPad8",
      "ingredients": [
        {
          "command": "window:move",
          "parameters": {
            "direction": "Up",
            "swap": true
          }
        }
      ]
    },
    {
      "name": "Swap window right",
      "hotkey": "Windows+Control+NumPad6",
      "ingredients": [
        {
          "command": "window:move",
          "parameters": {
            "direction": "Right",
            "swap": true
          }
        }
      ]
    },
    {
      "name": "Swap window down",
      "hotkey": "Windows+Control+NumPad2",
      "ingredients": [
        {
          "command": "window:move",
          "parameters": {
            "direction": "Down",
            "swap": true
          }
        }
      ]
    },
    {
      "name": "Center window",
      "hotkey": "Windows+NumPad5",
      "ingredients": [
        {
          "command": "window:center",
          "parameters": {}
        }
      ]
    },
    {
      "name": "Maxmize (No Region)",
      "hotkey": null,
      "ingredients": [
        {
          "command": "window:maximize",
          "parameters": {
            "window": "",
            "monitor": ""
          }
        }
      ]
    }
  ],
  "monitor": {
    "idSelection": "ByProperties",
    "virtualDesktop": false
  },
  "errorReporting": {
    "anonymityLevel": "MachineIdentifier",
    "enabled": true
  },
  "presets": [
    {
      "type": "split",
      "splits": {
        "orientation": "Vertical",
        "distance": 0.5,
        "child1": null,
        "child2": null
      },
      "name": "Two-way vertical"
    },
    {
      "type": "split",
      "splits": {
        "orientation": "Horizontal",
        "distance": 0.5,
        "child1": null,
        "child2": null
      },
      "name": "Two-way horizontal"
    },
    {
      "type": "split",
      "splits": {
        "orientation": "Vertical",
        "distance": 0.33346394769076981,
        "child1": null,
        "child2": {
          "orientation": "Vertical",
          "distance": 0.5,
          "child1": null,
          "child2": null
        }
      },
      "name": "Office2K-Left"
    },
    {
      "type": "split",
      "splits": {
        "orientation": "Vertical",
        "distance": 0.25019317388376167,
        "child1": null,
        "child2": {
          "orientation": "Vertical",
          "distance": 0.33341941595722113,
          "child1": null,
          "child2": null
        }
      },
      "name": "Office2K-Right"
    },
    {
      "type": "split",
      "splits": null,
      "name": "Office4K-Mid"
    }
  ]
}
@vegardlarsen

This comment has been minimized.

Member

vegardlarsen commented Oct 8, 2018

Can you try setting "runElevated": false instead and see if that "solves" the problem?

@derek-shnosh

This comment has been minimized.

derek-shnosh commented Oct 8, 2018

Can you try setting "runElevated": false instead and see if that "solves" the problem?

@vegardlarsen, this change did resolve the issue.

@vegardlarsen

This comment has been minimized.

Member

vegardlarsen commented Nov 6, 2018

This issue will be resolved in 2.0.0-beta.2.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment